cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Kepware Connection to Thingworx 7.x

SOLVED
Highlighted
Regular Member

Kepware Connection to Thingworx 7.x

Hi everybody,

 

I have a problem with the connection between Kepware and Thingworx 7.x, and I am running out of ideas. I have set up this previously between Thingworx 8.x and Kepware, but I can´t find how to do it on the older version. 
I have downloaded the Kepserver extension from the marketplace, added it on the composer and generated a Thing based on that ThingTemplate. 

Then I have configured the Project-> Thingworx on Kepware as shown on the image. I know the port is the 8444 since it is the one that I use for connecting to the composer (I have several webservices running on the machine). I have added an AppKey that I created on Thingworx to the Application Key field, and the "Kepware" is the name of the Thing that I created using the Kepware extension as ThingTemplate.

 

After setting it like this, I am getting a "Could not establish a websocket connection" error all the time (second image)

Am I missing something?

 

Regards,
JNanin

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Kepware Connection to Thingworx 7.x

When you browse to ThingWorx Composer are you using http:// or https:// 

The setting Disable Encryption: Yes means you should be using http://

 

The other thing to check is the appKey is not expired and does not have an extra <cr> at the end. Using copy and paste sometimes adds extra characters. 

View solution in original post

6 REPLIES 6

Re: Kepware Connection to Thingworx 7.x

When you browse to ThingWorx Composer are you using http:// or https:// 

The setting Disable Encryption: Yes means you should be using http://

 

The other thing to check is the appKey is not expired and does not have an extra <cr> at the end. Using copy and paste sometimes adds extra characters. 

View solution in original post

Re: Kepware Connection to Thingworx 7.x

Thank you very much! In all the explanations that I saw, the Disable Encryption had to be "Yes", but on my case that was the problem. I tried changing all the other parameters, adding rules to the firewalls, then taking down the firewalls completely, trusting certificates, etc etc. But I didn't think that on my case I needed the encryption enable.

Thanks again

Re: Kepware Connection to Thingworx 7.x

Hi again, sorry to bother you but I have encountered an extra problem.

So now that I have finally connected Kepware with Thingworx but I can't seem to add the tags that I have on Kepware itself. If I use the BrowseItems or BrowseGroups service, I can see my tags on the Channel + PLC that I specify on path, but if I try to add Property with Remote Binding using the Remote Prop Name with Channel1.Device1.Tag1 for example, I can't seem to retrieve any data. 

 

Then I thought that maybe I needed to use the "addItems" Service to add tags to Kepware, and then they would get added automatically to the properties, but I am getting an error on Kepware that says "Attempt to add item 'Channel.Device1.Tag4' failed" (for example), so I don't know if I am using a wrong syntax or if I still have something that it is not set up right.

 

In Thingworx 8.x this is so straightforward compare to this one :-/

Re: Kepware Connection to Thingworx 7.x

Is the version of ThingWorx older than 7.4? If it is you need to set "Legacy Mode" to "Enabled"

 

https://community.ptc.com/t5/ThingWorx-Developers/Procedure-to-integrate-Thingworx-with-KEPServerEX-...

 

 

Re: Kepware Connection to Thingworx 7.x

Yes, I have the legacy mode enabled. I took a look on that post, but I couldn’t find anything for my actual situation.

Regards,
JNanin

Re: Kepware Connection to Thingworx 7.x

I have found out what the problem was. I needed to use normal properties without local/remote bindings and create them before trying to adding the items.

Thanks for the help

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________