cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Kepware and Thingworx connectivity

SOLVED
Regular Member

Kepware and Thingworx connectivity

Hi,

I am running Thingworx 8.2 and Kepware 6.3

I followed the guide here :

http://support.ptc.com/help/thingworx_hc/thingworx_8_hc/en/#page/ThingWorx%2FHelp%2FComposer%2FIndus...

 

When I look at the Thing properties, I see Interface connected.

Unfortunately, I can't get "Industrial Connections" section visible.

 

In Kepware log, I can see errors like : *

Date Time Level Source Event
3/31/2019 3:42:20 PM Error ThingWorx Native Interface Error adding item. | Item name: ''.
3/31/2019 3:42:20 PM Error KEPServerEX\Runtime Attempt to add item 'Hostname' failed.

 

I can't understand what I am doing wrong, any idea ?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Kepware and Thingworx connectivity

Hi @SSNX.

 

I didn't notice it before, but try disabling legacy mode.

 

If that doesn't work, try the actual server name and validate the App key.

 

Regards.

 

--Sharon

6 REPLIES 6

Re: Kepware and Thingworx connectivity

Hi @SSNX.

 

In the hostname field for KepWare, have you tried with either localhost, the server name, or the server IP address?  I assume since you're using the localhost IP address, you're running both ThingWorx and Kepware on the same server, correct?

 

Regards.

 

--Sharon

Re: Kepware and Thingworx connectivity

Yes, I am running both on the same server computer.

I have tried "localhost" and "127.0.0.1" and this is the same.

Re: Kepware and Thingworx connectivity

Hi @SSNX.

 

I didn't notice it before, but try disabling legacy mode.

 

If that doesn't work, try the actual server name and validate the App key.

 

Regards.

 

--Sharon

Highlighted

Re: Kepware and Thingworx connectivity

I have disabled legacy Mode and now I get the following messages :

 

ThingWorx Diagnostics       
subscribedPropsMgr_Initialize: subscribed property values will not persist to disk while offline because the offline message directory was not set or the offline message store was disabled

 

I have checked Thingworx composer and still this "industrial connectivity" missing :(

 

For info, I am using the following guide :

http://support.ptc.com/help/thingworx_hc/thingworx_8_hc/en/#page/ThingWorx%2FHelp%2FComposer%2FIndus...

Re: Kepware and Thingworx connectivity

I think it is just a warning message.

I can see that my "Thing" is now showing property "IsConnected" to true.

 

How can I query a tag ?

Re: Kepware and Thingworx connectivity

Everything works like a charm.

That was my mistake. After connecting Kepware, I got a new button I have not seen "New Composer"

From there, I am able to brows my tags.

 

All good.