cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mashup load event is not firing at the mashup start

bmitioglov
Newbie

Mashup load event is not firing at the mashup start

Hi,

I binded several services  to mashup load event and all they are not executing at the start of mashup. But if I bind them to the button everything is ok.

Why mashup load event is not firing? Maybe I do something wrong...

Tags (1)
6 REPLIES 6

Re: Mashup load event is not firing at the mashup start

Hi Boris Mitioglov,

Could you please explain us the procedure you have followed to bind the services to mashup load event?

Re: Mashup load event is not firing at the mashup start

Yes of course.

I add the service to DynamicThingsTemplate_{ThingTemplateName} and check the "Mashup Loaded?" checkbox.

I can see in the connections pane that it was binded to the service. But my service which request some 3rd party API was not called.

When I call this service manually from thing services tab by "Test" button everything is working fine, so I can decide that the problem is with Mashup Loaded event.

Also I tried to do that with ThingStart event on thing's subscriptions and call my necessary services there and it was not working too.

Re: Mashup load event is not firing at the mashup start

Hi Boris Mitioglov,

Could you please do the following steps and share the results to track the issue:

  • Click on View Mashup
  • Once the mashup opens under a new browser, click on Show/Hide Debug Info button.

  • This will open a sub window within the same browser tab.

  • Enable Mashup Parameter, Services, Bindings and Mashup Trace.

  • Now, Cick on Start Trace -> Reload -> Stop Trace (do not perform F5/Refresh as that will close this sub window)


Please share the Trace screen as shown below to debug the issue.

Thank you!

Re: Mashup load event is not firing at the mashup start

Hi Yamini Tella,

Did everything as you said. Trace log is in the attach.

Re: Mashup load event is not firing at the mashup start

Hi Boris Mitioglov,

From the trace log, I have observed that the mashup load event is successfully triggered.

Could you please review if the services have properly bound to the widgets? Also, please provide a snapshot/screenshot  of your service bindings in the mashup. I would highly appreciate it if you can provide them.

Re: Mashup load event is not firing at the mashup start

Hi Yamini Tella,

I think the root of the problem is the H2 database. It is connected with the Persisted properties are loaded from time to time​, I thought that mashup load event was not fired, but now I think it was fired but properties were not filled cause DB problem.

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.