cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

PDF Extension not working

SOLVED
Highlighted
Level 8

PDF Extension not working

Good day All,

I am having difficulties getting the PDF Extension available from the Marketplace to work on Thingworx 8.0.2 (I am working with the latest version released 28 September 2017).

The CreatePDF service when tested executes indefinitely as in the screenshot with no Error messages in the Application logs or Script logs and no file being created in the Repository.

My inputs are:

     ThingWorxUser - Administrator

     ThingworxPassword - <Admin password>

     FileRepository: SystemRepository

     ServerAddress: http://<servername:port/Thingworx/Runtime/index.html#mashup=test

     OutputFileName: test.PDF

     Resolution: 1366*768

I tried to troubleshoot to get error messages. The only error message I could produce was if the resolution was not in the correct format (e.g. 1366x768). If I entered incorrect users or password nothing happens, also no error message if the ServerAddress is something non-sensical.

I have tested on a server running Thingworx 8.0.7 as well as Thingworx 7.xx versions and there it worked. Is there an incompatibility that was fixed in the later Thingworx version that anybody is aware of? Or maybe an input or permission issue?

Any suggestions?

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions

Re: PDF Extension not working

Hi @rflanagan,

 

The solution to our problem was captured in the thread below:

https://community.ptc.com/t5/ThingWorx-Developers/PDFExport-not-working-on-Red-Hat-Linux/td-p/530697...

 

The comment by JohanStrydom in the thread describes the problem.  The issue in short for us was related to Thingworx being deployed in a virtual container without a GUI. Once we installed some GUI packages the pdf extension worked.

 

I hope this helps.

Kind regards

2 REPLIES 2

Re: PDF Extension not working

I'm experiencing the same issue in 8.2.1. Anyone have a solution?

Re: PDF Extension not working

Hi @rflanagan,

 

The solution to our problem was captured in the thread below:

https://community.ptc.com/t5/ThingWorx-Developers/PDFExport-not-working-on-Red-Hat-Linux/td-p/530697...

 

The comment by JohanStrydom in the thread describes the problem.  The issue in short for us was related to Thingworx being deployed in a virtual container without a GUI. Once we installed some GUI packages the pdf extension worked.

 

I hope this helps.

Kind regards