cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Probleme with Upgrade from 7.3 to 7.4.7

Highlighted
Garnet

Probleme with Upgrade from 7.3 to 7.4.7

Hello

I'm trying to upgrade from 7.3 to 7.4.7 (MED-61111-CD-074_SP7_ThingWorx-Platform-Postgres-7-4-7.zip) on Ubuntu using postgres

I have followed the document Upgrading to ThingWorx 7.4  and the chapter  "In-place Upgrade to ThingWorx 7.4 (Neo4j/PostgreSQL/MS SQL Server/H2) on Ubuntu"


Unfortunately I cannot connect anymore to the Composer, the Browser says "ERR_CONNECTION_REFUSED"

I even reboot the server without sucess


I have this error in catalina.out

03-Jan-2018 17:51:38.572 SEVERE [main] org.apache.coyote.AbstractProtocol.init Failed to initialize end point associated with ProtocolHandler ["http-nio-80"]

java.net.BindException: Address already in use

I'm using https to connect to the Composer

Something changed between 7.3 to 7.4 or something to reconfigure when upgrading ?


Thanks

Pascal


4 REPLIES 4
Highlighted

Re: Probleme with Upgrade from 7.3 to 7.4.7

To complete

If I restore the Thingworx.war from 7.3 and restart tomcat8 evrything works again

so the issue seems for me in the Thingworx.war in 7.4.7

Regards

Highlighted

Re: Probleme with Upgrade from 7.3 to 7.4.7

Hello pjoly​,

Regarding the error that you mentioned, could you please check this article: Article Viewer | PTC

Highlighted

Re: Probleme with Upgrade from 7.3 to 7.4.7

hello

  • This error means that the Apache Tomcat port is already in use
  • Either the port number needs to be changed to an open port or the application blocking the configured Tomcat port must be shutdown to release the port

I read this article but I did not change the ports between 7.3 and 7.4 and I did  not add any new applications when I start the 7.4.

I do the 2 tests on the same server, just replacing  one file "thingworx.war" for 7.3 and 7.4

it works fine with 7.3 and I have this error in 7.4 ?

What is different for 7.4 for this tomcat port ?

Regards

Pascal

Highlighted

Re: Probleme with Upgrade from 7.3 to 7.4.7

Hello Pascal,

I would like to have a remote session with you on the ticket that you have with the TS Support team ****4373.

Could you reply in that TS case, so we can synchronaze on a convenient time frame?

Thank you!

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!