cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

QueryPropertyHistory service no storing any data

Pratik_Aswale
11-Garnet

QueryPropertyHistory service no storing any data

Hello,

I have a simple remote thing and 1 property which is logged and persist the data change is also set to value.

It is getting data from Kepware using industrial connection, on composer it is changing data but on QuryPropertyHistory no data is reflecting please check screenshot.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Installed a fresh new DB and it working fine now, I guess there was some issue in backed corruption of data.

 

Thanks.

View solution in original post

16 REPLIES 16

Hi @Pratik_Aswale 

 

Do you see any error message related to remote thing in Application log?

 

Also check whether you have assigned ValueStream to remote thing

 

/VR

Hello,

There are no errors in application logs and I have also attached VS to remote thing

Did you assign a value stream to the thing?

Yes I have assigned a value stream

Sorry, missed that in your other reply. To isolate the problem: When you remove the binding and update the value manually, does it work then?

Hi ,

I removed the binding and manually changed the values still I am getting blank infotable in service

now add a new property, just logged, not persisted, no index, and try with that one. Also try restarting the platform, if possible.

Hi,

I have created a new property with only log enabled, and also restarted tomcat. Still no result. PFA

Ok last resort is to switch the thing to another VS. If that doesn't work, create a ticket with support.

Hi,

I tried switching VS not helped, I have opened support ticket. Thanks for the help

Once this is resolved, please post the resolution here for everyone's learning.

Yeah Sure

Hi @Pratik_Aswale 

 

One last suggestion, have you tried after restarting Platform & Database ?

 

/VR

Yes I have restarted Platform and DB

Hello,

I noticed a strange thing QueryPropertyHistory is working when I change property data type to String.

PFA

Installed a fresh new DB and it working fine now, I guess there was some issue in backed corruption of data.

 

Thanks.

Top Tags