cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Single Scroll bar whole Responsive Mashup

pshashipreetham
17-Peridot

Single Scroll bar whole Responsive Mashup

Hi,

 

I have a responsive mashup, It has three main Sub Containers...

1st Sub Container has Grid
2nd Sub Container has Collection Widget

3rd Sub Container has another Grid widget


My Screen resolution is 1920*1080, now I see all three Subcontainer are having Scroll bars, which the Customer doesn't want.

 

Is there a way, My Main Container has a vertical Scroll bar and sub-containers can expand as much as they can, without having any scroll bars?

Thingworx version: 9.3.8

 

Thanks,

Shashi Preetham
1 ACCEPTED SOLUTION

Accepted Solutions

I got it working by enabling the contained advanced-grid EnableContainerScroll property.

You can then disable horizontal and vertical scrolling. The grid will fill up the container with all of its content.

 

Also you need to make sure all child containers have scrolling disabled while parent container have scrolling enabled

View solution in original post

4 REPLIES 4

Hello @pshashipreetham,

 

I feel like I remember reading something about this where you could have only the parent container have a scrollbar.

But unfortunately I can't remember where I read it.

 

Did you try using this:

jensc_0-1683895686065.png

And turning it off for the sub containers?

 

Regards,

Jens

HI @jensc ,

 

Vertical Scroll bars are disabled/grayed out for all sub-containers, so it didn't work.

 

Thanks,

Shashi Preetham

I got it working by enabling the contained advanced-grid EnableContainerScroll property.

You can then disable horizontal and vertical scrolling. The grid will fill up the container with all of its content.

 

Also you need to make sure all child containers have scrolling disabled while parent container have scrolling enabled

Thank you, @rogerjn. It worked like magic.

Shashi Preetham
Top Tags