cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

ThingWorx fails to start after fresh installation

Re: ThingWorx fails to start after fresh installation

Could you please supply your ApplicationLog found in the ThingworxStorage/logs directory?

Re: ThingWorx fails to start after fresh installation

Hi Polina,

File is attached. Thanks in advance.

Re: ThingWorx fails to start after fresh installation

The platform is not connecting to your database:

2017-08-17 21:13:26.803+0300 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-2] *** Web Application STATE is being set to ERROR! ***

What is your Postgresql version? Have you run the DBsetup and SchemaSetup scripts? To verify, please open pgadmin III and expand your thingworx database to the tables level and see how many were created (should be around 57).

Also please attach your platform-settings.json

Re: ThingWorx fails to start after fresh installation

Hi Polina,

I'm using PostgreSQL 9.4.13.

Yes I ran DBSetup and SchemaSetup scripts. Please see the 58 tables created.

platform-settings.json file is attached.

Re: ThingWorx fails to start after fresh installation

Hi Ozgur Aslan,

Please provide full access to the user for /ThingworxPlatform, /ThingworxStorage and /ThingworxPostgrSQLStorage folders.

Re: ThingWorx fails to start after fresh installation

Hi Yamini,

All folders have full access.

I'm still suspicious about Tomcat - HTTP/1.1.

access log:

0:0:0:0:0:0:0:1 - - [17/Aug/2017:22:31:12 +0300] "GET /Thingworx/Home HTTP/1.1" 401 -

0:0:0:0:0:0:0:1 - - [17/Aug/2017:22:34:51 +0300] "GET /Thingworx/Composer/index.html HTTP/1.1" 401 -

Re: ThingWorx fails to start after fresh installation

Hi Ozgur Aslan,

Are you able to see the tomcat screen when you key in http://localhost address in the web-browser? If you were able to see that screen then Tomcat has installed successfully.

Also, does the password in platform.settings file match with the twadmin password?

Re: ThingWorx fails to start after fresh installation

What if you swap the server.xml for the default one (without changing the protocol to org.apache.coyote.http11.Http11NioProtocol)?

Re: ThingWorx fails to start after fresh installation

Also, please make sure that you have license.bin file in /ThingworxPlatform folder and set the license path(C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps\Thingworx\WEB-INF\extensions) to the environment variables as shown below:

Also, verify that the PostgreSQL installtion/bin folder (C:\Program Files\PostgreSQL\9.4\bin) is added to the system path variable..

Re: ThingWorx fails to start after fresh installation

Hi All,

1.Yes I can see even the Tomcat Manager screen.

2. The password in platform.settings file match with the twadmin password.

3. The license.bin file is in /ThingworxPlatform folder

4. The license path is added (C:\Program Files\Apache Software Foundation\Tomcat 8.5\webapps\Thingworx\WEB-INF\extensions) to the environment variables as Yamini told.

5. PostgreSQL installtion/bin folder (C:\Program Files\PostgreSQL\9.4\bin) was already added to the system path variable

6. I swapped the server.xml for the default one (without changing the protocol to org.apache.coyote.http11.Http11NioProtocol) but still the same message in access log.


Actually I'm out of solutions...