cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx 8.1 - Not starting

SOLVED
Highlighted

Thingworx 8.1 - Not starting

Hi,

I having Thingworx 8.1 with H2 Persistence Provider. While try to launch TWX, Tomcat itself not loading. In Application log, i am getting an info like "HA mode not enabled. Initializing and starting in standalone mode." . 

How can i resolve this?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Thingworx 8.1 - Not starting

Thanks for your response.

I think this issue was related with DB. I just replaced the H2Backup file. Now it is working fine. 

Once again thanks for your kind reply.

10 REPLIES 10

Re: Thingworx 8.1 - Not starting

Hi @Sathishkumar_C,

 

This is not the error, it is only INFO which is not the actual cause of ThingWorx not starting.

Please check the application logs and check for errors which is causing the issue.

 

Also make sure you have proper license file installed, all the tomcat configurations (java options) are correct and compatible software - JDK/Tomcat are installed on your machine.

 

If still you are unable to resolve the issue, please share the application logs.

We will have a look on that to find the cause.

 

 

Thanks,

Himanshu

Re: Thingworx 8.1 - Not starting

Please find attached Tomcat log file

Re: Thingworx 8.1 - Not starting

Please find Thingworx application log.

Re: Thingworx 8.1 - Not starting

Hi Sathish,

 

Please do check the if the JavaOptions in the Java tab of the Configure Tomcat is correct. 

For example :  "-Djava.library.path=C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps\Thingworx\WEB-INF\extensions", check if this path exist in your system. This might also be a reason for the tomcat not being able to start.

 

Regards

Saran

Re: Thingworx 8.1 - Not starting

Yeah I can able to find path in Java options.

Re: Thingworx 8.1 - Not starting

Hi Sathish,

 

I meant to say check the path "C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps\Thingworx\WEB-INF\extensions" exist in you file explorer. Sometimes when you copy paste from the Installation guide you might miss some characters.

 

Regards,

Saran

Re: Thingworx 8.1 - Not starting

Thanks for your valuable response.

I can able to see the folder called "extensions" on my pc. And also i have checked my Java options path. It was correct only.

Re: Thingworx 8.1 - Not starting

I got the same tomcat error logs for the issue i mentioned. I think the problem is from the tomcat side or else you might have got a better explanation in the Application logs. Anyway i'm out of ideas and hope your issue gets resolved.

 

Regards

Saran

Re: Thingworx 8.1 - Not starting

@Sathishkumar_C,

 

Could you please share the screenshot of Java Options tab of your tomcat configuration