cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx HA

SOLVED
vi1
Amethyst

Thingworx HA

Hi,

 

I am configuring HA for Thingworx.

I have installed Zookeeper 3.5.5 and configured Zoo.cfg.Also created myid file.

After that, i am trying to start Zookeeper and unable to start Zookeeper server. I am getting the error. I have attached screenshot what i am getting error.Could you please help on that.

 

Regards,

Latha

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Thingworx HA

I've just understood -- your myid has ".txt" extension! Remove this extension, it should be called just "myid", then it will work. Keep double slashes though.

 

/ Constantine

View solution in original post

15 REPLIES 15

Re: Thingworx HA

Hi @vi1.

 

You might try checking stackoverflow for resolving Zookeeper start up issues.  If that doesn't help, you'll need to Google it for other possibilities.

 

Regards.

 

--Sharon

Highlighted

Re: Thingworx HA

Hello,

 

Can you confirm that you have a directory "apache-zookeeper-3.5.5" under c:\zookeeper?

 

/ Constantine

Re: Thingworx HA

Hi,

 

Yes, I have created folder "apache-zookeeper-3.5.5" under c:\Zookeeper. please find the attached screenshot.

 

Thank You

Re: Thingworx HA

And I assume you have complete Zookeeper installation inside this folder? Can you take another screenshot of its content, please?

Re: Thingworx HA

Thank you.

Here attaching complete folder content screenshot.

 

Regards,

Latha

Re: Thingworx HA

You downloaded Zookeeper's source code instead of the binary distribution. Go back to Downloads and get the one with "-bin" in its name, e.g. "apache-zookeeper-3.5.5-bin.tar.gz".

Re: Thingworx HA

Hi,

 

Thank you for information.

 

I have downloaded bin folder and copied. Still unable to start the server and getting the errors.

Please refer the attached screenshot.

 

Regards,

Vidyullatha

 

Re: Thingworx HA

Also, attached conf folder content screenshot.

Re: Thingworx HA

I see on your screenshot an error message, which says that your "conf/zoo.cfg" file is invalid, so I guess you need to take a look at it. Here's explained how to configure it on Linux: https://www.ptc.com/en/support/article?n=CS241504

 

/ Constantine

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________