cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx Platform supported postgres versions

sri_kundula
5-Regular Member

Thingworx Platform supported postgres versions

We are using Thingworx Platform 8.5.5 and PostgreSQL 10.8 in AWS. PostgreSQL 10 has become obsolete now and AWS will upgrade the database to v11 soon. The system requirements guide shows that TWX 8.5 only supports 10.8. Is there a plan to support more postgres versions?

 

Regards,

Sri

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @sri_kundula ,

There is no other option to upgrade you TWX to 9.0+ version to use Postgres 11 or 13..

Thanks,
Shashi

View solution in original post

2 REPLIES 2

Hi @sri_kundula ,

There is no other option to upgrade you TWX to 9.0+ version to use Postgres 11 or 13..

Thanks,
Shashi

Hi @sri_kundula,

ThingWorx 8.5.x is out of support since Sept 26, 2021. There are no plans to support this release.

I strongly suggest upgrading to ThingWorx 9.3.x, which supports at the time of this writing PostgreSQL 11.13, 12.8 and 13.4.

 

 

Announcements