cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx: Status 401 or white screen

Highlighted

Re: Thingworx: Status 401 or white screen

Hi andrey,

just curious how about you edit 'T' letter with Uppercase in the json file:

"jdbcUrl": "jdbc:postgresql://localhost:5432/thingworx",

to

"jdbcUrl": "jdbc:postgresql://localhost:5432/Thingworx",

for me it success to make tomcat running stable (it stopping automatically soon after starting, before) the deploy the TWX and i reach white screen now

Re: Thingworx: Status 401 or white screen

Your database is not running or is not installed properly . Its the issue with DB for sure.

2017-07-18 15:41:26.406+0700 [L: ERROR] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: http-nio-80-exec-9] [message: Connections could not be acquired from the underlying database!]

Re: Thingworx: Status 401 or white screen

Hi Anugrah             

Thanks for the advice!
The letter "T" in the register depends on the name of the database.
At me it is written with a small letter (thingworx)
When changing a letter, I have an error in my logs about the fact that there is no such database.
So it did not help me.

I do not understand why, when I write the correct login and password in the file "platform-settings.json", the tomcat will not start

Re: Thingworx: Status 401 or white screen

Likely due to it trying to connect to the db and failing. At this point, I would run the DB cleanup script and then re-run DB Setup and Schema setup scripts. Please ensure no errors occur (ideally, you'll be prompted to enter password during the first setup script and see nothing else, and enter password a couple of times for the second script).

You may also add this for the license: 7.4 Thingworx does not launch due to license error in Windows

Re: Thingworx: Status 401 or white screen

Hi Andrey,

firstly, I apologize if my advice leads you to another trouble with tomcat server stopping (it's happened with me when I switch the 'T', tomcat stopped soon after I started, even when I have switched back to original). I get ride the problem with undeploy the thingworx.war, delete the folder ThingworxStorage, and ThingworxBackupStorage (also keysession in folder ThingworxPlatform if using thingworx 8.0). You can start again the tomcat. and then re-deploy the thingworx.war

second, my problem now Solved, and I can open the composer. So I would thanks to you for your answer 'the register depends on the name of the database' , because it reminds me of the database problem (from Ravi answer above, 'Your database is not running or is not installed properly . It's the issue with DB for sure.') and I think this all caused by same problem 'Database'. In my case, I'm using:

"jdbcUrl": "jdbc:postgresql://localhost:5432/Thingworx",

an Uppercase T of Thingworx in file platform-settings.json, although my database and my tablespace using lowercase 't'. and everything is working except the result is a white blank screen, it is strange since you must have the consistency between database and platform-settings.json. I remember before that I have trouble when creating the database using the script, i make several attempts with inconsistency database name (Thingworx/thingworx), so I think somehow it must be the culprit, maybe Postgres have some memory reside and I didn't do the database deleting clean.


so this is my step:

1. I undeploy the thingworx.war (using Tomcat management or just deleting Thingworx folder and Thingworx.war inside <tomcat path>/webapps).

2. I delete the database using script:

thingworxPostgresDBCleanup -h localhost -p 5432 -d thingworx -t thingworx -a postgres -b postgres

   

    (make sure u doing it with administrator, for me using cmd terminal and go to the folder where the .bat file placed)

3. I modify the <PGDATA>/pg_hba.conf (where <PGDATA>  for me C:\Program Files\PostgreSQL\9.4\data ) so the file is like this :

# TYPE  DATABASE        USER            ADDRESS                METHOD

# IPv4 local connections:

host    all            all            127.0.0.1/32            trust

# IPv6 local connections:

host    all            all            ::1/128                trust

# Allow replication connections from localhost, by a user with the

# replication privilege.

#host    replication    postgres        127.0.0.1/32            md5

#host    replication    postgres        ::1/128                md5

    (warning this causing security problem since we modify METHOD from md5 to trust, I recommend this step ONLY for testing in isolated machine/network. and please try to switches back to md5 after making sure this step is not the problem cause)

4. re-creating database

thingworxpostgresDBSetup -h localhost -p 5432 -d thingworx -t thingworx -a postgres -u twadmin -l C:\ThingworxPostgresqlStorage

   

5. creating scheme

thingworxPostgresSchemaSetup -h localhost -p 5432 -d thingworx -s public -u twadmin -o all

6. put platform-settings.json in the <root>\ThingworxPlatform folder. (after setting to proper configuration)

7. deploy Thingworx.war

8. open go to <servername>/Thingworx in a Web browser. hope it works.

Re: Thingworx: Status 401 or white screen

Anugrah, many thanks!
But version 8.0.1 not started.
But the version 7.2 was launched (without using PostgreSQL)

The start occurred after the file ".war" was replaced.
The question about the start of 8.0 remains open.

Re: Thingworx: Status 401 or white screen

yeah, you're right, thanks Ravi, it leads me to the solution.