cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thingworx first install

SOLVED
Highlighted
Participant

Thingworx first install

Hi,

I'm trying to perform the first install On thingworx core 8. So far the PostgreSQL database is created and both scripts ran with no problem.

When trying to acess the platform through http://localhost/Thingworx i am only getting a blank page. Them localhost_acess_log on tomcat dysplays:

0:0:0:0:0:0:0:1 - - [21/Jul/2017:11:52:57 -0300] "GET /Thingworx HTTP/1.1" 302 -

0:0:0:0:0:0:0:1 - - [21/Jul/2017:11:52:57 -0300] "GET /Thingworx/Home HTTP/1.1" 401 -

0:0:0:0:0:0:0:1 - - [21/Jul/2017:12:10:32 -0300] "GET /Thingworx HTTP/1.1" 302 -

0:0:0:0:0:0:0:1 - - [21/Jul/2017:12:10:32 -0300] "GET /Thingworx/Home HTTP/1.1" 401 -

0:0:0:0:0:0:0:1 - - [21/Jul/2017:12:17:45 -0300] "GET /Thingworx HTTP/1.1" 302 -

0:0:0:0:0:0:0:1 - - [21/Jul/2017:12:17:45 -0300] "GET /Thingworx/Home HTTP/1.1" 401 -

Believing that this is a 401 error I've tried the recommendations on Frequently Seen Errors upon launching the Thingworx application​ concerning the 401 error, but with no sucess so far.

I've changed only the password in the JSON file on the Platform.

I am using the following software:

Microsoft Windows 10 Pro 10.0.15063 N/A build 15063

Tomcat 8.5

PostgreSQL 9.4.12

Do you know of any steps I did wrong or missed?

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Thingworx first install

Hello, Marcel.

Did you do this step (from about page 8 of the ThingWorx 8 Install Guide)

http://support.ptc.com/WCMS/files/173115/en/Installing_ThingWorx_8.0_1.1_.pdf

Go to the location of the Tomcat installation and open the server.xml file in the conf folder. For example, C:\Program Files\Apache Software Foundation\Tomcat 8.0\conf\server.xml

Replace HTTP/1.1 with protocol="org.apache.coyote.http11.Http11NioProtocol"



​Looks like it's still trying to use HTTP/1.1 in your error messages.

-- Craig A.

View solution in original post

2 REPLIES 2
Highlighted

Re: Thingworx first install

Hello, Marcel.

Did you do this step (from about page 8 of the ThingWorx 8 Install Guide)

http://support.ptc.com/WCMS/files/173115/en/Installing_ThingWorx_8.0_1.1_.pdf

Go to the location of the Tomcat installation and open the server.xml file in the conf folder. For example, C:\Program Files\Apache Software Foundation\Tomcat 8.0\conf\server.xml

Replace HTTP/1.1 with protocol="org.apache.coyote.http11.Http11NioProtocol"



​Looks like it's still trying to use HTTP/1.1 in your error messages.

-- Craig A.

View solution in original post

Highlighted

Re: Thingworx first install

Hello Craig,


I did it before but my file had syntax errors. I had Tomcat reinstalled to make sure and did the replace command on the service.xml file instead of changing it manually.


I have acess to the platform now. Thank you for the hint!

Marcel.

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!