cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

We are working to address an issue with subscription email notifications. In the meantime, be sure to check your favorite boards for new topics.

Thingworx server not connecting

AP_9587236
17-Peridot

Thingworx server not connecting

My thingworx instance was working fine. Suddenly now it shows

"Errors

503 Service Unavailable

Back to Composer". 
What to do now? 
1 ACCEPTED SOLUTION

Accepted Solutions

This error not occuring after installation. Thingworx was working fine for years, suddenly this error happened. Thanks for your help.

 

I cleared this error "12:13:21.173 [main] ERROR com.thingworx.system.configuration.PlatformSettings - Configuration setting ContentTypeSettings.supportedMediaEntityContentTypes cannot be null" in logs. Its working now. 
 
So i added this code in platform-settings.json.
"ContentTypeSettings": {
"supportedMediaEntityContentTypes":["image/svg+xml","image/png","image/gif","image/bmp","image/jpeg","application/pdf", "application/json", "image/vnd.microsoft.icon"]
}

 

View solution in original post

6 REPLIES 6
cmorfin
19-Tanzanite
(To:AP_9587236)

Hi @AP_9587236 

 

You can check the Tomcat and ThingWorx log files to check for errors and possibly restart Tomcat

 

Hope this helps

Regards

Christophe

 

Sorry this is not a accepted solution. By mistake i clicked the button. 

 

Btw @cmorfin , i tried restarting tomcat, cleared logs, updated chrome, restarted system, checked platform-setting file, cleared storage space in machine, no other apps are  running. But still thingworx server is not connecting but tomcat is working fine. 

 

I seen error in twdata of pgAdmin. I attached the image. Does that matters? 

 

And I can see these errors in Application logs:-

2021-08-24 15:40:30.229+0530 [L: ERROR] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: main] [message: Connections could not be acquired from the underlying database!]
2021-08-24 15:40:30.255+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: main] [message: Unable to initialize and start system: Connections could not be acquired from the underlying database!]
2021-08-24 15:40:30.255+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: main] *** CRITICAL ERROR ON STARTUP: Unable to initialize and start system: Connections could not be acquired from the underlying database!
2021-08-24 15:40:30.255+0530 [L: ERROR] [O: c.t.s.ThingWorxBootstrapper] [I: ] [U: SuperUser] [S: ] [T: main] *** Web Application STATE is being set to ERROR! ***

cmorfin
19-Tanzanite
(To:AP_9587236)

Hi @AP_9587236 

 

Can you upload tomcat and ThingWorx log files ?

 

regards

Christophe

 

I attached tomcat logs here. And thingworx logs file exceeds limit. Kindly download from this link. 

https://drive.google.com/file/d/1srnivIufO8ukjnDH77MQWL5ACrkvYHv8/view?usp=sharing

cmorfin
19-Tanzanite
(To:AP_9587236)

@AP_9587236 

 

I see from your other post that you identify the root cause, basically ThingWorx cannot connect to Postgres.

The article https://www.ptc.com/en/support/article/CS235937 should help you isolate what is wrong.

 

regards

Christophe

 

This error not occuring after installation. Thingworx was working fine for years, suddenly this error happened. Thanks for your help.

 

I cleared this error "12:13:21.173 [main] ERROR com.thingworx.system.configuration.PlatformSettings - Configuration setting ContentTypeSettings.supportedMediaEntityContentTypes cannot be null" in logs. Its working now. 
 
So i added this code in platform-settings.json.
"ContentTypeSettings": {
"supportedMediaEntityContentTypes":["image/svg+xml","image/png","image/gif","image/bmp","image/jpeg","application/pdf", "application/json", "image/vnd.microsoft.icon"]
}

 

Top Tags