cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thwx 7.4: Failed to load FlxCore library

SOLVED
Highlighted
Newbie

Thwx 7.4: Failed to load FlxCore library

I wanted to give v7.4 a spin this afternoon, so I grabbed the Neo version and spun it up, with the new license file in the ThingworxPlatform folder.

Tomcat starts and then stops. Application log at shutdown:

2017-03-24 14:00:16.908-0600 [L: INFO] [O: c.t.s.s.Subsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Starting Subsystem [LicensingSubsystem]

2017-03-24 14:00:16.987-0600 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-03-24 14:00:16.987-0600 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)I

2017-03-24 14:00:16.987-0600 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-03-24 14:00:16.987-0600 [L: WARN] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Shutting down the Platform.

Looking around, I did spot, 'webapps\Thingworx\WEB-INF\extensions\FlxCore64.dll'

Anyone have any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi Jason

For the error message, have you tried what is indicated in the error message:

"Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path."

it works for me after adding <Tomcat>\webapps\Thingworx\WEB-INF\extensions in PATH variable (I am on Windows)

Also how do you start Tomcat ? I seem to recall the startup.bat did have the path as a java argument. Maybe you are using a different way that do not load this file, but adding the environment variable should help.

Regarding the license file, as this stage, the license file is only linked to the software version and not a specific environment, so there is no customer specific license file.

Hope this help

Kind regards

Christophe

View solution in original post

29 REPLIES 29
Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Also a question on the license file. How do we get our company's license file created?

What is the license file that comes with the installer?

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi Jason

For the error message, have you tried what is indicated in the error message:

"Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path."

it works for me after adding <Tomcat>\webapps\Thingworx\WEB-INF\extensions in PATH variable (I am on Windows)

Also how do you start Tomcat ? I seem to recall the startup.bat did have the path as a java argument. Maybe you are using a different way that do not load this file, but adding the environment variable should help.

Regarding the license file, as this stage, the license file is only linked to the software version and not a specific environment, so there is no customer specific license file.

Hope this help

Kind regards

Christophe

View solution in original post

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Yes, thanks. I added it to the path after reading the error but, uh, spelled Tomcat as "Tomcart" and big surprise, it didn't work.

It worked fine once I learned to copy and paste.

I don't believe this is in the new Install or upgrade document.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi Jason

I am happy that it worked for you ... typos are always very entertaining

Regarding the guide, I just checked the installation guide and it does mention to add the path to WEB-INF/extensions page 10 for Windows and page 36 for Linux.

The guide add it as a  -Djava.library.path argument to Tomcat, but the result is the same.

Kind regards

Christophe

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Good spot, I scanned that list and it looked the same to me as previous versions. I am  Thanks for the help, I appreciate it. I think I am overworked!!!

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

I am getting the same issue. I tried this solution but it did now work. My ThingWorx platform folder is in the OS(C:) directory and also contains the license file. Cannot figure out what the issue is. Any suggestions?

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Rishit Shah​,

Try adding <Tomcat>\webapps\Thingworx\WEB-INF\extensions in PATH variable in the System environment variables.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Thank you for the response Ankit. I added it and I am still having the same issue.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

@rishit Have you already checked this 7.4 Thingworx does not launch due to license error in Windows

Can you also share your application log/tomcat log? Which OS are you working with?

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Sushant Pandey

I did try the solution in link you have posted. The application log is as below

2017-04-24 10:52:44.621-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-24 10:52:44.621-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)I

2017-04-24 10:52:44.623-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-24 10:52:44.623-0500 [L: WARN] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Shutting down the Platform.

Please let me know if I need to post any other portion of the log as well.

Thanks in advance

Update: I am working with Windows 10

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi Rishit

Could you post the output of the following:

-open a command prompt on your Windows machine and execute set PATH

post the output here.

Also in the same command prompt could you navigate to <Tomcat>\webapps\Thingworx\WEB-INF\extensions folder and execute the command dir, and post the output here too .

Thanks

Christophe

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Below are the responses:

1) On executing the set PATH

\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\nodejs\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\PostgreSQL\9.6\bin;C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.5\webapps\Thingworx\WEB-INF\extensions;C:\Windows\System32\wbem;C:\Users\rishi\Anaconda3;C:\Users\rishi\Anaconda3\Scripts;C:\Users\rishi\Anaconda3\Library\bin;C:\Users\rishi\AppData\Local\Microsoft\WindowsApps;C:\Python27;C:\Python27\Scripts;C:\Program Files\Git\usr\bin;C:\Program Files\Heroku\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Users\rishi\AppData\Roaming\npm;C:\Users\rishi\AppData\Local\Google\Cloud SDK\google-cloud-sdk\bin;C:\Program Files\Docker Toolbox;C:\Program Files\PostgreSQL\9.6\bin;C:\Windows\System32\wbem

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

2) On executing dir command

Volume in drive C is OS

Volume Serial Number is 38D8-5C7C

Directory of C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.5\webapps\Thingworx\WEB-INF\extensions

04/23/2017  04:18 PM    <DIR>          .

04/23/2017  04:18 PM    <DIR>          ..

03/22/2017  02:05 PM         8,837,096 FlxCore64.dll

03/22/2017  02:05 PM         7,400,560 libFlxCore.2016.08.dylib

03/22/2017  02:05 PM         4,315,316 libFlxCore.so.2016.08

03/22/2017  02:05 PM         4,650,664 libFlxCore64.so.2016.08

03/20/2017  11:18 PM               140 readme.txt

               5 File(s)     25,203,776 bytes

               2 Dir(s)  882,745,126,912 bytes free

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

It seems you are running Tomcat 8.5. Please downgrade to Tomcat 8.0.x - 8.0.33 (minimum).

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

I downgraded to tomcat 8.0.33 and still having the same issue.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

When you downgraded Tomcat, is it still in the same location , C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.5, or in some other location ?

How do you start Tomcat: as a service or as a program (executing the startup.bat script) ?

in any case, could you try the following:

-  open a NEW command prompt

- execute set PATH

- ensure that the path to <Tomcat>\webapps\Thingworx\WEB-INF\extensions is listed there (make sure the path to Tomcat is correct if it has changed due to downgrade - NOTE if you need to update the PATH variable do open a NEW command prompt after updating the PATH variable)

- move to <Tomcat>/bin

- execute startup.bat

if it still fails, could you post:

- startup.bat

- output of set PATH (again in case there is a change of directory after downgrade)

It is important to open a new command prompt after updating the PATH variable in Control Panel as an already opened commmand prompt will not see the update of environment variable.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Christophe,

I start tomcat using catalina.bat run as startup.bat window disappears after execution without allowing me to copy/troubleshoot the error message.

I updated the path to new variable as per the location of the new tomcat directory. However I am still getting the same issue. Below is the result of set path with new location of tomcat 8.0.33.

Path=C:\ProgramData\Oracle\Java\javapath;C:\Python27;c:\windows\system32;C:\HashiCorp\Vagrant\bin;C:\Program Files\Git\cmd;C:\Program Files\Git\usr\bin;C:\Program Files (x86)\PuTTY\;C:\Users\rishi\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\nodejs\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\PostgreSQL\9.6\bin;C:\Windows\System32\wbem;C:\Users\rishi\Desktop\Rishit_Nevotek\IOT\apache-tomcat-8.0.33\webapps\Thingworx\WEB-INF\extensions;C:\Users\rishi\Anaconda3;C:\Users\rishi\Anaconda3\Scripts;C:\Users\rishi\Anaconda3\Library\bin;C:\Users\rishi\AppData\Local\Microsoft\WindowsApps;C:\Python27;C:\Python27\Scripts;C:\Program Files\Git\usr\bin;C:\Program Files\Heroku\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Users\rishi\AppData\Roaming\npm;C:\Users\rishi\AppData\Local\Google\Cloud SDK\google-cloud-sdk\bin;C:\Program Files\Docker Toolbox;C:\Program Files\PostgreSQL\9.6\bin;C:\Windows\System32\wbem;C:\Users\rishi\Desktop\Rishit_Nevotek\IOT\apache-tomcat-8.0.33\webapps\Thingworx\WEB-INF\extensions

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

Below is the output of catalina.bat run as startup.bat makes the window disappear after execution

Expecting an absolute path of the library: FlxCore.dll

2017-04-28 14:15:48.512-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-28 14:15:48.512-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)I

2017-04-28 14:15:48.512-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-28 14:15:48.512-0500 [L: WARN] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Shutting down the Platform

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi Rishit

Could you zip up all the .bat file from <Tomcat>/bin and post them here ?

Thanks

Christophe

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Christophe,

Please find the bin zip file below

Also, I have been facing the same issue on ubuntu machine as well. Please let me know if you need anything from there. Also, I have no db associated with thingworx on my windows machine. However, for my ubuntu machine I attempted linking it with SAP HANA DB that is installed in our office server. Not sure if this information is relevant for this particular issue but I though I should mention it

Thanks and Regards,

Rishit

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi Rishit

I tried your bin directory on my installation and it does work.

Could you please try with a 64bits version of Tomcat instead of a 32bits version.

Officially only 64bits version is supported.

Also, from what you described,  the error you get on Ubuntu is different, with some access denied issues.

I would recommend you double check the installation guide especially the chmod and chown commands.

If still issue, please open a new discussion so we can keep the issues separate.

Thanks

Christophe

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Thank you for the response Christophe. After making some suggestions by Polina Osipova below, it worked for me as well. The tomcat server starts up but I get HTTP status 500 when trying to access /Thingworx URL. I believe this could be an error with my server.xml file. I have attaced the file here. Please check and let me know if you find an error.

Thanks


Rishit

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

What are yoyr tomcat java settings?

Try this without the java path to the license file (in addition to the default settings):

-Dserver -Dd64

-XX:+UseNUMA

-XX:+UseConcMarkSweepGC

-Dfile.encoding=UTF-8

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

I could not find the windows service option for tomcat 8.0.33 as stated in the documentation. As a result I had to download the zip file. I do not have the configure tomcat window coming up. Can you please tell me how do I configure these options?

Thanks

Update: I tried installing the same in ubuntu with Hana DB. when I execute the command, "sudo catalina.sh run", it fails with a similar error as above. However if I execute the command "catalina.sh run", the tomcat server starts up and is accessible on port 8080. However, /Thingworx URL is not accessible. The errors seem to state that it fails to initiate /Thingworx due to inability to create various directories in /ThingoworxStorage and /ThingworxBackupStorage. In either cases, it also throws a fileNotFoundException for the .keystore file.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Polina,

Thanks a lot. This worked. However I am getting a 500 internal server error while trying to access localhost:8080/Thingoworx. I believe this could be an error in my server config file. Please take a look at the attached file. Below are the logs from my command prompt.

02-May-2017 10:51:09.900 SEVERE [localhost-startStop-1] org.apache.jasper.EmbeddedServletOptions.<init> The scratchDir you specified: C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.0\work\Catalina\localhost\ROOT is unusable.

02-May-2017 10:51:09.901 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web application directory C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.0\webapps\ROOT has finished in 135 ms

02-May-2017 10:51:09.908 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]

02-May-2017 10:51:09.917 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-8009"]

02-May-2017 10:51:09.922 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 101208 ms

2017-05-02 10:51:22.617-0500 [L: ERROR] [O: c.t.s.a.AuthenticationFilter] [I: ] [U: ] [S: ] [T: http-nio-8080-exec-3] null

First time a pop up window asked for login credentials. I entered Adminstrator and admin as mentioned the documentation. I have been getting this error ever since.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Stop tomcat, remove your server.xml and  try with this one (rename it to server.xml first):

Note this file uses port 80, so you would be accessing your application on http://localhost/Thingworx

In case it still doesn't work - please attach your ApplicationLog.log found in ThingworxStorage/logs

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Polina,

Since port 80 was already in use by another application, I tried port 8080. It still gives the same error. Please find the attached Applcation log

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

At this point let's open a separate thread and troubleshoot in there.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

Hi,

I have a 32-bit processor machine and I am able to run 7.2 version of thingworx but whenever I am trying to deploy 7.4 version, getting below error

"Expecting Absolute path of Library Flxcore64.dll"

Note: I am simply copying thingworx.war in the web-apps folder of tomcat and already configured all the java related parameters in the tomcat.

Highlighted

Re: Thwx 7.4: Failed to load FlxCore library

32-bit processor is not supported. But you can try following:

Path of FlxCore64.dll is <Tomcat>\webapps\Thingworx\WEB-INF\extensions.

You can try to add the <Tomcat>\webapps\Thingworx\WEB-INF\extensions in PATH variable in the System environment variables.

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum!