cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Thwx 7.4: Failed to load FlxCore library

SOLVED

Re: Thwx 7.4: Failed to load FlxCore library

Sushant Pandey

I did try the solution in link you have posted. The application log is as below

2017-04-24 10:52:44.621-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-24 10:52:44.621-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)I

2017-04-24 10:52:44.623-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-24 10:52:44.623-0500 [L: WARN] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Shutting down the Platform.

Please let me know if I need to post any other portion of the log as well.

Thanks in advance

Update: I am working with Windows 10

Re: Thwx 7.4: Failed to load FlxCore library

Hi Rishit

Could you post the output of the following:

-open a command prompt on your Windows machine and execute set PATH

post the output here.

Also in the same command prompt could you navigate to <Tomcat>\webapps\Thingworx\WEB-INF\extensions folder and execute the command dir, and post the output here too .

Thanks

Christophe

Re: Thwx 7.4: Failed to load FlxCore library

Below are the responses:

1) On executing the set PATH

\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\nodejs\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\PostgreSQL\9.6\bin;C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.5\webapps\Thingworx\WEB-INF\extensions;C:\Windows\System32\wbem;C:\Users\rishi\Anaconda3;C:\Users\rishi\Anaconda3\Scripts;C:\Users\rishi\Anaconda3\Library\bin;C:\Users\rishi\AppData\Local\Microsoft\WindowsApps;C:\Python27;C:\Python27\Scripts;C:\Program Files\Git\usr\bin;C:\Program Files\Heroku\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Users\rishi\AppData\Roaming\npm;C:\Users\rishi\AppData\Local\Google\Cloud SDK\google-cloud-sdk\bin;C:\Program Files\Docker Toolbox;C:\Program Files\PostgreSQL\9.6\bin;C:\Windows\System32\wbem

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

2) On executing dir command

Volume in drive C is OS

Volume Serial Number is 38D8-5C7C

Directory of C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.5\webapps\Thingworx\WEB-INF\extensions

04/23/2017  04:18 PM    <DIR>          .

04/23/2017  04:18 PM    <DIR>          ..

03/22/2017  02:05 PM         8,837,096 FlxCore64.dll

03/22/2017  02:05 PM         7,400,560 libFlxCore.2016.08.dylib

03/22/2017  02:05 PM         4,315,316 libFlxCore.so.2016.08

03/22/2017  02:05 PM         4,650,664 libFlxCore64.so.2016.08

03/20/2017  11:18 PM               140 readme.txt

               5 File(s)     25,203,776 bytes

               2 Dir(s)  882,745,126,912 bytes free

Re: Thwx 7.4: Failed to load FlxCore library

It seems you are running Tomcat 8.5. Please downgrade to Tomcat 8.0.x - 8.0.33 (minimum).

Re: Thwx 7.4: Failed to load FlxCore library

I downgraded to tomcat 8.0.33 and still having the same issue.

Re: Thwx 7.4: Failed to load FlxCore library

Hi,

I have a 32-bit processor machine and I am able to run 7.2 version of thingworx but whenever I am trying to deploy 7.4 version, getting below error

"Expecting Absolute path of Library Flxcore64.dll"

Note: I am simply copying thingworx.war in the web-apps folder of tomcat and already configured all the java related parameters in the tomcat.

Re: Thwx 7.4: Failed to load FlxCore library

32-bit processor is not supported. But you can try following:

Path of FlxCore64.dll is <Tomcat>\webapps\Thingworx\WEB-INF\extensions.

You can try to add the <Tomcat>\webapps\Thingworx\WEB-INF\extensions in PATH variable in the System environment variables.

Re: Thwx 7.4: Failed to load FlxCore library

When you downgraded Tomcat, is it still in the same location , C:\Program Files (x86)\Apache Software Foundation\Tomcat 8.5, or in some other location ?

How do you start Tomcat: as a service or as a program (executing the startup.bat script) ?

in any case, could you try the following:

-  open a NEW command prompt

- execute set PATH

- ensure that the path to <Tomcat>\webapps\Thingworx\WEB-INF\extensions is listed there (make sure the path to Tomcat is correct if it has changed due to downgrade - NOTE if you need to update the PATH variable do open a NEW command prompt after updating the PATH variable)

- move to <Tomcat>/bin

- execute startup.bat

if it still fails, could you post:

- startup.bat

- output of set PATH (again in case there is a change of directory after downgrade)

It is important to open a new command prompt after updating the PATH variable in Control Panel as an already opened commmand prompt will not see the update of environment variable.

Re: Thwx 7.4: Failed to load FlxCore library

Christophe,

I start tomcat using catalina.bat run as startup.bat window disappears after execution without allowing me to copy/troubleshoot the error message.

I updated the path to new variable as per the location of the new tomcat directory. However I am still getting the same issue. Below is the result of set path with new location of tomcat 8.0.33.

Path=C:\ProgramData\Oracle\Java\javapath;C:\Python27;c:\windows\system32;C:\HashiCorp\Vagrant\bin;C:\Program Files\Git\cmd;C:\Program Files\Git\usr\bin;C:\Program Files (x86)\PuTTY\;C:\Users\rishi\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\nodejs\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\PostgreSQL\9.6\bin;C:\Windows\System32\wbem;C:\Users\rishi\Desktop\Rishit_Nevotek\IOT\apache-tomcat-8.0.33\webapps\Thingworx\WEB-INF\extensions;C:\Users\rishi\Anaconda3;C:\Users\rishi\Anaconda3\Scripts;C:\Users\rishi\Anaconda3\Library\bin;C:\Users\rishi\AppData\Local\Microsoft\WindowsApps;C:\Python27;C:\Python27\Scripts;C:\Program Files\Git\usr\bin;C:\Program Files\Heroku\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Users\rishi\AppData\Roaming\npm;C:\Users\rishi\AppData\Local\Google\Cloud SDK\google-cloud-sdk\bin;C:\Program Files\Docker Toolbox;C:\Program Files\PostgreSQL\9.6\bin;C:\Windows\System32\wbem;C:\Users\rishi\Desktop\Rishit_Nevotek\IOT\apache-tomcat-8.0.33\webapps\Thingworx\WEB-INF\extensions

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

Below is the output of catalina.bat run as startup.bat makes the window disappear after execution

Expecting an absolute path of the library: FlxCore.dll

2017-04-28 14:15:48.512-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-28 14:15:48.512-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Failed to load FlxCore library. Ensure it's in PATH (Windows) or LD_LIBRARY_PATH(other platforms) or set with the VM arg, -Djava.library.path. Error message : com.flexnet.licensing.DllEntryPoint.entry([B)I

2017-04-28 14:15:48.512-0500 [L: ERROR] [O: c.t.s.s.l.LicensingSubsystem] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] ====================================================================

2017-04-28 14:15:48.512-0500 [L: WARN] [O: c.t.s.ThingWorxServer] [I: ] [U: SuperUser] [S: ] [T: localhost-startStop-1] Shutting down the Platform

Re: Thwx 7.4: Failed to load FlxCore library

What are yoyr tomcat java settings?

Try this without the java path to the license file (in addition to the default settings):

-Dserver -Dd64

-XX:+UseNUMA

-XX:+UseConcMarkSweepGC

-Dfile.encoding=UTF-8