cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to generate email from Thingworx 8.4.2

Sathishkumar_C
15-Moonstone

Unable to generate email from Thingworx 8.4.2

Hi All,

We are try to send email with Mailserver template. Facing below mentioned error.

 

Thingworx 8.4.2

MailExtension 3.6.0 / MailExtensions 3.5.1

.

Security Log:
Unable to send error email for logged incident: failed to connect, no password specified?
Error sending email due to [Could not connect to SMTP host: secure.emailsrvr.com, port: 465].The last server response was [null] with return code [0].The error originated on host [DESKTOP-EANFF4C].

ApplicationLog:
[message: Unable to Invoke Service SendMessage on MailServerThing : Unable to send error email for logged incident]

 

Thanks & Regards,

Sathishkuamr C.

9 REPLIES 9

Hi @Sathishkumar_C 

 

I came across these articles which might be helpful for you. Please take a look a these.

https://www.ptc.com/en/support/article?n=CS253881

https://www.ptc.com/en/support/article?n=CS200624

 

Thanks,

Vibhuti

Thanks for the quick reply.

 

I referred both the documents but i am not able to send email from "SendMessage" service.

 

Thanks.

@Sathishkumar_C 

Maybe the firewall is blocking or permissions issues.

 

Please refer this article https://www.ptc.com/en/support/article?n=CS236135

 

Thanks,

Vibhuti

Yes Vibhuti. I can able connect the mail server via telnet. But not able send email with service.

Hello,

 

465 is an SMTPS port, so make sure you select "Use TLS" checkbox.

 

/ Constantine

Showing error "Unable to Invoke Service SendMessage on MailServerThing : Exception reading response".

We made "Use TLS and Use SSL" both are true by that scenario facing an error link "

 Unable to Invoke Service SendMessage on MailServerThing : Could not connect to SMTP host: secure.emailsrvr.com, port: 465" 
 
Thanks.
 

@Sathishkumar_C Did you try "Use SSL" and "Use TLS" in all 4 possible combinations? Still the same error?

Hi Constantine,

I have attached the errors of possible combinations of  SSL and TLS. Email server is reachable which i have confirmed with telnet command.

 

SSL - true / TLS - true -> Unable to Invoke Service SendMessage on MailServerThing : Could not connect to SMTP host: secure.emailsrvr.com, port: 465

 

SSL - true / TLS - false -> Unable to Invoke Service SendMessage on MailServerThing : Could not connect to SMTP host: secure.emailsrvr.com, port: 465

 

SSL - false / TLS - false -> Unable to Invoke Service SendMessage on MailServerThing : Exception reading response

 

SSL - false / TLS - true -> Unable to Invoke Service SendMessage on MailServerThing : Exception reading response

Does it work for you when you configure some desktop client (e.g. Outlook, Thunderbird, etc.) with the same settings? Maybe your server blocks SMTP traffic or uses another port?..

Announcements