cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to show colors on pie chart

SOLVED
krishnakomal123
Alexandrite

Unable to show colors on pie chart

I tried  to bind colorformats dynamically on pie chart from an infotable service output . But colors are not applied on pie chart.Please find the attached screenshots.Let me know where It went wrong.Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Unable to show colors on pie chart

You just need to extend the original that I sent you to have more states & alter the service to take a 'type' input parameter.

K

 

View solution in original post

9 REPLIES 9

Re: Unable to show colors on pie chart

Hi,

 

Could you attach entities to reproduce this issue?

What version of Thingworx you are using?

 

Thank you,

Raluca Edu

Re: Unable to show colors on pie chart

As requested I have attached th xml file below.ON mashup load you can see a pie chart with colors left bottom.After clicking on right/left button beside pie chart,I am giving dynamic colors.Then it's not working.Thanks in advance

 

Thingworx version : 8.3.2

Re: Unable to show colors on pie chart

Is the answer that your info table should return something more like

PropertyName: SegmentName   (e.g. "MS" or "CUB")

PropertyValue :  300    (some integer value)

 

Then you need a state definition tied to the 'PropertyName' parameter to give you the colour you requiire. 

 

We use the pie chart for a similar thing and our infotable looks like this

khayes1_0-1583843655927.png

We then have a state definition like the below which is tied to the 'State' parameter:

khayes1_2-1583843825846.png

 

so rather than your infotable having a column for each type ("MS", "CUB" etc.) you have an infotable with one column for the type parameter and return a number of rows .

 

The pie chart is then bound to All Data from infotable service and the pie chart settings are set accordingly. In our case:

khayes1_3-1583844168600.png

 

 

 

Re: Unable to show colors on pie chart

I am not understanding to the fuller extent.Can you please attach file in xml?

Re: Unable to show colors on pie chart

I have attached a simple demo example. Import the files into your Thingworx then open/view the mashup to see how it works

 

Re: Unable to show colors on pie chart

Just realised that you will need to import this Model Tag file first, or files in zip archive may not import.

Re: Unable to show colors on pie chart

You did not get me.I am adding some more screenshots to explain you how it should work.In the screenshots below,If we click right/left button the values and colors should change for Water,Electricity,steam etc...I have mentioned wrong thingworx version before.This has been done using Adobe software.If you are able to do it,please share your files too.Thanks in advance.

 

I am working on 8.3.3

Re: Unable to show colors on pie chart

Please let me know if you figured it out.

Re: Unable to show colors on pie chart

You just need to extend the original that I sent you to have more states & alter the service to take a 'type' input parameter.

K

 

View solution in original post

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.