cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - If community subscription notifications are filling up your inbox you can set up a daily digest and get all your notifications in a single email. X

how to configure gridadvance widget

Yoshihiko.N
12-Amethyst

how to configure gridadvance widget

Dear Developers,

I cannot configure columns in grid (advance )widget even though I bound data to it.
we can see columns in the configuration menu when we use "grid (preview)" widgets.
Could you let me know if  we need additional process or not ?
ThingWorx 9.2.3-b189 )

YoshihikoN_0-1645672149392.pngYoshihikoN_1-1645672179599.pngYoshihikoN_2-1645672215323.png

 

7 REPLIES 7

Hi @Yoshihiko.N ,

 

We have article explaining, " How to configure Advance Grid Widget".

Pls find out the given link and let me know if it will help you:

https://www.ptc.com/en/support/article/cs318198

 

BR

Bhawna

Hi Bhawna,

thank you for your reply.
I looked the link and important point is data source need to have data shape to use "configure grid columns".  is is correct ?
I set a datashape but can nothing in the menu.

YoshihikoN_1-1646028889184.png

 




YoshihikoN_0-1646028833486.png

 

Hi Bhawna,

We have 2 ThingWorx servers and tried the same thing in the other sever.
and then, we can see the menu in "Configure grid columns".
use the same entites but we cannot see column menu in a server, but can see it in the other server.

Could you let me know what configuration may affect this difference ?


YoshihikoN_0-1646034885911.png

 

@Yoshihiko.N 

 

What is the Thingworx version of both the servers?

Hi 

the version of both are the same.

 

YoshihikoN_0-1646114534270.png

 

@Yoshihiko.N 

 

Export the Thing, mashup and all the other dependent entities from the server where its working fine and import them on the other server. Check if the issue disappears.

Hi 

Thank you for your proposal but I already tried it but we can see the difference that we can see the configuration menu in one TW bu cannot see it on the other TW even though the same version.

Announcements