cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

time not updating when adding a data table entry

SOLVED
Highlighted
Newbie

time not updating when adding a data table entry

Hi

I am using ThingWorx 7.1.0-b484 with Postgres.

However I am using the default TW storage and I have noticed a strange behaviour in my data tables. Whenever a new entry is added to tje data table it reflects the date in the default column "timestamp" but does not reflect the time and shows the time as: 2017-04-10 00:00:00.000 for instance.

Kindly help in fixing this.

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: time not updating when adding a data table entry

This bug is Jira TW-7373. Fixed in 7.1.4 (and later), 7.2.0+, 7.3.0+.

This problem was occuring in the Postgres and H2 versions of the Platform because they populate the timestamp for Data Table entries using the java.sql.Date class which doesn't persist hours, minutes, seconds, and milliseconds.

View solution in original post

2 REPLIES 2

Re: time not updating when adding a data table entry

This bug is Jira TW-7373. Fixed in 7.1.4 (and later), 7.2.0+, 7.3.0+.

This problem was occuring in the Postgres and H2 versions of the Platform because they populate the timestamp for Data Table entries using the java.sql.Date class which doesn't persist hours, minutes, seconds, and milliseconds.

View solution in original post

Re: time not updating when adding a data table entry

thanks Polina!

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________