cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

where I could find thingworx.war release 8 for training ?

Newbie

where I could find thingworx.war release 8 for training ?

Hello

I just want to download the thingworx.war release 8 for training, but I can't find it on the download site. I could find thingworx docker installer, utilities, platform postgress .... but not simply the .war

57 REPLIES 57

Re: where I could find thingworx.war release 8 for training ?

Isabelle Missaire​ : The .war file will be inside the ThingWorx Platform .zip file. If you have the platform postgres zip file then unzip it do get the Thingworx.war file.

-Durgesh

Re: where I could find thingworx.war release 8 for training ?

Thank you Durgesh, Indeed I can find it.

Another question please, when I deploy it on tomcat application, I had an issue around innaccebility site and I'm wondering if I miss the steps to fill "in the java Options field, type the appropriat java options, as described in the wiki" because I have not found the wiki. (extract from ThingWorx installation prerequisites (for all platforms document).

So I have not modified tomcat properties java and  I have :

-Dcatalina.home=C:\Tomcat

-Dcatalina.base=C:\Tomcat

-Djava.io.tmpdir=C:\Tomcat\temp

-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager

-Djava.util.logging.config.file=C:\Tomcat\conf\logging.properties

Moreover, I want to use tomcat 8.xx with java 1.7.xx : it is indicated as compatible.

Apache Tomcat/8.5.201.7.0_09-b05

thank you for your help

Re: where I could find thingworx.war release 8 for training ?

http://support.ptc.com/WCMS/files/173115/en/Installing_ThingWorx_8.0_1.3_.pdf

Please follow Tomcat configuration from the ThingWorx 8 installation guide starting page 5.

Go to Start->Configure Tomcat->Java Tab

And add the following lines

-Dserver -Dd64

-XX:+UseG1GC

-Dfile.encoding=UTF-8

-Djava.library.path=C:\Program Files\Apache Software Foundation\Tomcat 8.0\webapps\Thingworx\WEB-INF\extensions (please make sure you specify your path to the Tomcat->)

And, we recommend using jdk 1.8 . Please refer to the Thingworx 8 System Requirement document before you proceed with the installation.

http://support.ptc.com/WCMS/files/173114/en/ThingWorx_Core_8.0_System_Requirements_1.pdf

 

Re: where I could find thingworx.war release 8 for training ?

THank you very much for this guide, more detailed than which I used.

I have updated also java release to 1.8.0_144-b01

But when I deploy thingworx.war on tomcat application, I had always the issue around innaccebility site.

maybe environment varables to update ? in windows environment.

I have not install postgress yet, but for me, it is not the issu for the tomcat deployment.

Thank you for your help.

BR

Isabelle

Re: where I could find thingworx.war release 8 for training ?

Glad it helped! Is the platform still inaccessible? If so ,could you attach a screenshot of your java configuration?

Did you put the license.bin file in ThingworxPlatform folder? If not, please create the ThingworxPlatform folder in the root drive(default C:) and give it full access.

Re: where I could find thingworx.war release 8 for training ?

tomcat java configuration.png

I have also added :

optionsTomcatJava.png

but I can see others options in your screen about : endorsed, io.tmpdir I don't have

thank you

isabelle

Re: where I could find thingworx.war release 8 for training ?

Thank you, with license, I 'm progressing, I can see Thingworx started in tomcat application, but empty page with browser localhost/Thingworx while I'm waiting for "following login information".

I have ThingworxPlatform and ThingworxStorage folders created.

thank you for your help

Isabelle

Re: where I could find thingworx.war release 8 for training ?

Hi Isabelle,

Can you please share the Application log from ThingworxStorage folder and catalina.log from Tomcat logs folder?

Re: where I could find thingworx.war release 8 for training ?

thank you if you could help me. I have not install PostgreSQL yet.