cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

SOLVED
Highlighted
Participant

Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

Hello,

 

To start with, I am beginner in Thingworx. I just had my thingworx 7.1.19 installed with postgres as database. I brought up the UI and can able to navigate around and do basic entity creation like thing, thingtemplate etc...

 

Now trying to import the PTC Windchill extension (ptc-windchill-extension-1.6) into thingworx, but it fails and all I can see in log is below error message, not sufficient to troubleshoot, not sure what I am missing.

 

1. Is there any compatibility issue.

2. Am I missing any steps before importing the PTC windchill extension.

-----

Wrapped by: com.thingworx.extensibility.ExtensibilityException: An unexpected error occurred while uploading extension: null
 at com.thingworx.webservices.ExtensionPackageUploader.beginImport(ExtensionPackageUploader.java:183) ~[thingworx-platform-common-7.1.9-b54.jar:na]
 at com.thingworx.webservices.ExtensionPackageUploader.service(ExtensionPackageUploader.java:101) ~[thingworx-platform-common-7.1.9-b54.jar:na]
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:729) [servlet-api.jar:na]
 at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:292) [catalina.jar:8.0.41]
 at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:207) [catalina.jar:8.0.41]
 at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52) [tomcat-websocket.jar:8.0.41]
 at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:240) [catalina.jar:8.0.41]

 

----

 

Thanks with your help!

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

Hi @mkumar-10-11-126,

 

The versions for Navigate compatibility are very much sensitive. We need to have exact version of ThingWorx i.e. 8.1.3 for this. Also there is a sequence you need to follow to import the extensions. There are dependencies for this, so if any extension is not imported, rest will also face problems.

The sequence should be:

  1. Google Maps Widget
  2. Mail Extensions
  3. Web Sockets Tunnel Widget and Library
  4. ThingWorx-Utilities-{version}.zip
  5. grid-advanced_ExtensionPackage:3.0.5
  6. ptc-windchill-extension-{version}.zip
  7. ptc-windchill-utilities-extension-{version}.zip
  8. ptc-sample-mashup{version}.xml
  9. ptc-navigate-framework-extension-{version}.zip
  10. ThingWorx-NavigateView-PLM-App-Extension-Bundle-{version}.zip
  11. ThingWorx-Navigate-Example-{version}.xml

 

Let me know if this works, or if you have any questions.

 

BR,

Harsh Selarka

View solution in original post

4 REPLIES 4

Re: Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

Hi mkumar,

 

Can you let me know what is the exact usecase for importing ptc-windchill-extensions in ThingWorx? Are you planning to use ThingWorx Navigate to fetch data from Windchill? If so, you need to be using all the compatible software and extensions. Please refer to Software Matrix for ThingWorx Navigate.

 

Let me know if this helps.

 

BR,

Harsh Selarka

Re: Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

Hi Harsh, thanks for replying and for your valid inputs. And yes the intention is connecting to windchill.

 

Yes, I did checked the compatibility and it all looks good.Also I tried with different versions of thingworx.

 

The latest thingworx version I tried is as follows,

  1. Thingworx 8.1.5-b150 ( I guess the upward compatibility should be fine)
  2. Postgresql 9.4.17
  3. Thingworx extension (ptc-windchill-extension-1.8.0-01)
  4. IE11

 

 

Re: Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

Hi @mkumar-10-11-126,

 

The versions for Navigate compatibility are very much sensitive. We need to have exact version of ThingWorx i.e. 8.1.3 for this. Also there is a sequence you need to follow to import the extensions. There are dependencies for this, so if any extension is not imported, rest will also face problems.

The sequence should be:

  1. Google Maps Widget
  2. Mail Extensions
  3. Web Sockets Tunnel Widget and Library
  4. ThingWorx-Utilities-{version}.zip
  5. grid-advanced_ExtensionPackage:3.0.5
  6. ptc-windchill-extension-{version}.zip
  7. ptc-windchill-utilities-extension-{version}.zip
  8. ptc-sample-mashup{version}.xml
  9. ptc-navigate-framework-extension-{version}.zip
  10. ThingWorx-NavigateView-PLM-App-Extension-Bundle-{version}.zip
  11. ThingWorx-Navigate-Example-{version}.xml

 

Let me know if this works, or if you have any questions.

 

BR,

Harsh Selarka

View solution in original post

Re: Cannot Import 'ptc-windchill-extension-1.6.0-01' extension into Thingworx 7.1.19

Hi @mkumar-10-11-126,

Just wanted to follow up to see if Harsh's feedback and steps helped to resolve your issue.  If so,  please indicate his response as an Accepted Solution.  If not, please let us know your current status.

Thanks!

Leigh