cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Fixed account authentication configuration for navigate

SOLVED
bkulkarni
Contributor

Fixed account authentication configuration for navigate

Hello,

  Could you please share me the process of Fixed account authentication configuration for navigate.

  we have not configure windhill without SSL. Please share process.

 

Regards,

Bhagyashree

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Fixed account authentication configuration for navigate

In Thingworx :

  • Open ptc-windchill-integration-connector and select Configuration
    • Set Authentication Type to None
    • Fill out Username and Password
    • Fill the Base URL with: http://<Windchill Hostname>:<port>/Windchill/trustedAuth (instead of sslClientAuth)
    • Click Save.
  • Open ptc-windchill-integration-connector-proxy and select Configuration             
    • URL: http://<Windchill Hostname>
    • Set Authentication Type to basic
    • Fill out Username, Password
    • Do not specify path for Keystore and TrustStore
    • (Starting Navigate 1.8) : Set "Test Connection URL"=http://<SERVER_NAME>/Windchill/servlet/WindchillAuthGW/wt.httpgw.HTTPServer/echo
    • (Starting Navigate 1.8) Enable Dynamic Content

In Windchill :

  • Add property below in wt.properties :
    • wt.auth.trustedHosts=<HOSTNAME_THINGWORX_SERVER>

View solution in original post

6 REPLIES 6

Re: Fixed account authentication configuration for navigate

In Thingworx :

  • Open ptc-windchill-integration-connector and select Configuration
    • Set Authentication Type to None
    • Fill out Username and Password
    • Fill the Base URL with: http://<Windchill Hostname>:<port>/Windchill/trustedAuth (instead of sslClientAuth)
    • Click Save.
  • Open ptc-windchill-integration-connector-proxy and select Configuration             
    • URL: http://<Windchill Hostname>
    • Set Authentication Type to basic
    • Fill out Username, Password
    • Do not specify path for Keystore and TrustStore
    • (Starting Navigate 1.8) : Set "Test Connection URL"=http://<SERVER_NAME>/Windchill/servlet/WindchillAuthGW/wt.httpgw.HTTPServer/echo
    • (Starting Navigate 1.8) Enable Dynamic Content

In Windchill :

  • Add property below in wt.properties :
    • wt.auth.trustedHosts=<HOSTNAME_THINGWORX_SERVER>

View solution in original post

Re: Fixed account authentication configuration for navigate

I have done setting as mentione dby you but when i put below url it throw error while saving

(Starting Navigate 1.8) : Set "Test Connection URL"=http://<SERVER_NAME>/Windchill/servlet/WindchillAuthGW/wt.httpgw.HTTPServer/echo

so i have changed to http://<server_name>/Windchill so it save.

But now when i click validate service its failing i have attached log .Please let me know your comment

Re: Fixed account authentication configuration for navigate

While saving ptc-windchill-integration-connector-proxy, it invokes ValidateConnection service of ptc-windchill-integration-connector. Please modify ptc-windchill-integration-connector firstly and make sure ValidateConnection service could execute successfully.

Also, make sure to enable the Dynamic Content check box.

Re: Fixed account authentication configuration for navigate

Hello
I have done setting in ptc-wondchill-integration connector as metion in above comment also checked dynamic content any other setting I need to do. Please let me know.

Re: Fixed account authentication configuration for navigate

Thank you all for your reply my IR service was not running due to which it not validating connection not its up.

Re: Fixed account authentication configuration for navigate

Hi @bkulkarni.

 

If one of the previous replies answered your question, please mark the appropriate one as the Accepted Solution for the benefit of others with the same question.

 

Regards.

 

--Sharon

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.