cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting Error while Thingworx-Navigate1.5 Installation

Regular Member

Getting Error while Thingworx-Navigate1.5 Installation

Hi ,

I am using below components after referring Navigate Support Matrix document:

Thingworx 8.0.1 H2,

Thingworx Utilities 8.0.1, Windchill Extension 1.7, Navigate Framework 1.4.1

Windchill 11.0 M030

Note: I have successfully installed patch WCTWXExtension in windchill, I have imported every component and extension without any error as mentioned in guide "Thinworx Navigate Installation and Configuration guide".

 

I am getting error when I am trying to test the connection by running Validate Connection service in ptc-windchill-integration-connector. ​I am getting status as Failed ​and I am getting some error in application log. I have attached log file.

Can anyone guide/help me with this?

 

Tags (2)
7 REPLIES 7
Highlighted

Re: Getting Error while Thingworx-Navigate1.5 Installation

In the title you mention Navigate 1.5 but later on, Navigate 1.4.1 -- which one is it?

Note that 1.4 would not be supported with ThingWorx 8 and Windchill extension 1.7 https://support.ptc.com/WCMS/files/173209/en/Navigate_Support_Matrix.pdf

Re: Getting Error while Thingworx-Navigate1.5 Installation

Navigate Framework used is 1.4 and Navigate view is 1.5.2.

Navigate Framework 1.4 is supported by Thingworx 8.0.1 H2 as per matrix.

Re: Getting Error while Thingworx-Navigate1.5 Installation

Unable to install Navigate 1.4.0 with Thingworx

Re: Getting Error while Thingworx-Navigate1.5 Installation

The Navigate version (1.5, 1.6, etc.) is the version of the Navigate View PLM App Extension. The other extensions are versioned according to the sequence in which they were updated, and so the version numbers on those extensions do not match the Navigate version. The matrix is the only way to be sure how the extension versions match up with the Navigate version.

 

Getting the versions to match correctly can be critical. For example, Navigate 1.5.0 uses Navigate Framework 1.4.0, while Navigate 1.5.2 uses Navigate Framework 1.4.1. They are not necessarily interchangeable.

Re: Getting Error while Thingworx-Navigate1.5 Installation

The most helpful log for the failed Validate Connection test is the IntegrationRuntime log, which is usually stored in the same folder that the IntegrationRuntime jar was run from.

Re: Getting Error while Thingworx-Navigate1.5 Installation

Navigate 1.5.2 requires a complicated configuration of SSO in PingFederate. Navigate 1.6.0 and later include authentication options that are easier to configure, as well as the PingFederate option. If this is your first install of Navigate, I recommend using Navigate 1.6.0 if you can.

Re: Getting Error while Thingworx-Navigate1.5 Installation

Hi @SandeepRatnani,

 

Which use case you are using for Navigate 1.5.x? Are you using PingFederate or Fixed authentication?

Also are you able to run the Integration Runtime successfully? If so, please share the IR logs.

 

BR,

Harsh Selarka