cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

PTC Navigate installation issue.

Highlighted
Participant

PTC Navigate installation issue.

Hi,  I'm trying to install and configure PTC Navigate in Thingworx 7.1.

I follow every single steps and It works fine untill i try to import the "PTCNavigate_Example-1.3.0-04-imports.xml" file. It throws me the next error:

Error importing: error, Import Failed: Validation Failure: Thing CompositeEpmDocumentResourceProvider Had An Invalid Thing Template : [PTC.Resource.FlattenedCompositeResourceProviderTemplate]


Here is an image if you want to check it..


I would appreciate your help. Thank You.

9 REPLIES 9
Highlighted

Re: PTC Navigate installation issue.

Ronald, are you following an import sequence? It's missing a Template, most likely from another Entity import. Are there any other xml files remaining?

Highlighted

Re: PTC Navigate installation issue.

Hi, Aanjan, Thank you for your response.

Yes, I've followed every step on the installation guide, importing all files with success except  that one.

Highlighted

Re: PTC Navigate installation issue.

Highlighted

Re: PTC Navigate installation issue.

Did you import the 'TWX_Converge_Core_ExtensionPackage' extension already? It's part of the ThingWorx Utilities package.

Highlighted

Re: PTC Navigate installation issue.

Yes, I did. Actually, It was the first package i imported.

Highlighted

Re: PTC Navigate installation issue.

If so, do you have a template called "PTC.Resource.FlattenedCompositeResourceProviderTemplate"?

Highlighted

Re: PTC Navigate installation issue.

No, I don't have it.

Highlighted

Re: PTC Navigate installation issue.

Please try re-importing the 'TWX_Converge_Core_ExtensionPackage' as that seems to have the Thing Template you're missing.

Highlighted

Re: PTC Navigate installation issue.

I already did it. Like three times and did the same with the other packages.

Announcements