cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

SOLVED
Highlighted
Regular Member

The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

Hello,

I am new to thingworx navigate. 

I have written a service where it pulls data based on part number. While executing the service. I get below error.

 

"The requested URL /sslClientAuth/servlet/rest/search/objects was not found on this server". Below is my code snippet. 

 

var params = {
type: 'GET',
url: me.getRestUrl() + "/search/objects",
queryParams: {
'$select': properties,
'$filter': "number eq '" + number + "'",
'navigationCriteria': navigationCriteria,
'typeId': selectedTypeId
}
};


var jsonResult = me.processJSONRequest(params);

 

can anyone please let me know what's wrong with the code?

 

Thanks,

RPathan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

Change the baseURL under your thing-->configuration. In my case I didn't provide Windchill. After modifying the baseURL, the issue got resolved. This is what I provided. Replace localhost with your server name. 

https://localhost:443/Windchill

 

I hope this helps.

5 REPLIES 5

Re: The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

The issue is resolved now.

Re: The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

what change di dyou make to fix this issue?

Re: The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

Change the baseURL under your thing-->configuration. In my case I didn't provide Windchill. After modifying the baseURL, the issue got resolved. This is what I provided. Replace localhost with your server name. 

https://localhost:443/Windchill

 

I hope this helps.

Re: The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

thank you for response.

For me '443' is not working, intead '80' is working and have baseURL set same as yours.

 

Still i am getting 404 error everytime i run service same as you have given above.

if i run URL directly in browser, JSON is returning the result

If i run service for that JSON, then getting 404 error

 

 

Re: The requested URL /sslClientAuth/servlet/rest/search/objects was not found in Thingworx navigate

443 is not working, means you have not configured https. That's fine. Don't use the same base URL as the mine one. In your case it might be something like this http://yourserver.com:80/Windchill. 

just make sure your application identifier is Windchill only, also it's case sensitive. I have put Windchill, because that's how it is for my server.