cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Chalk performance issue

Highlighted
Aquamarine

Chalk performance issue

Hi,

 

I have recently tested Vuforia Chalk for Desktop (Chrome Version 85.0.4183.83) and  Vuforia Chalk on mobile device (iPhone 6s, IOS 13.0) with potential customers and we experienced serious performance issues during the session. The network bandwidth between the desktop and iPhone is good and should not be an issue to support Chalk video session.

 

What we observed is that after 5 minutes into the session, we noticed the session on Chalk for Desktop prompting us warning that the network is "poor", and it automatically switched to low bandwidth mode. Immediately, the session is cut off and we see nothing on the screen (desktop), although the Chalk on mobile device is still sharing the session. The Chalk for Desktop then went into a hang state where we have to kill the session by refreshing the browser (Chrome latest version), and  re-initiate another session. The behavior is repeatable after we tried several rounds of initiating new sessions.

 

Even during the session, some annotations didn't anchor to their positions and worse, some of them disappear.  Sometimes, initiating a new session (clicking "Start Session") to generate a connect code using Chalk for Desktop takes a few minutes, despite having good network bandwidth. It seems that Chalk for Desktop performance is not really stable.

 

Anyone has experienced the similar situation, and be able to shed some lights on how to overcome this?

 

Thank you.

 

 

3 REPLIES 3
Highlighted

Re: Chalk performance issue

Hi @WilsonT 

 

If you try Chalk for Desktop paired with a different device, do you see the same results? There is a known issue with older iOS devices that is currently degrading the call quality due to the OS management of resources. We have a fix for this planned in the next release of Chalk. Putting the iPhone into A/V only mode should increase the call quality until that time. 

 

Have you tried clearing your browser cache or using an incognito browser for C4D?  

Highlighted

Re: Chalk performance issue

Hi @tmccombie ,

 

Thanks for your reply.

 

I tried with 11 inch iPad Pro (iOS 13.4.1) and it gave the same observation.  I was using Chrome in Incognito mode to ensure there is no cache that might affect the browser performance for C4D.

 

I did see some posts mentioning about the known issue of older iOS devices, and tried to explain to the customers. Since iPhone 6S is listed as one of the officially supported devices, it's difficult to convince with this reason. Furthermore, setting the A/V only mode defeats the purpose of using Chalk (Annotation is the key differentiator as compared to normal video call) albeit the better call quality. 

 

Customer is trying to resolve this issue before scaling up to the entire organization. Is there a way to collect any message log for further investigation?

 

Appreciate your help.

Re: Chalk performance issue

While the 6s is a supported device, it is part of the affected devices of this issue/bug. We have seen this issue in other iOS devices as well and have a fix for this slated in the September release of Chalk. Waiting for this fix is most likely the best option as it would be hard to diagnose other potential issues with this known one present. 

 

 

Announcements
Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection