cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Cant see local experience service from vuforia view

II_9204674
11-Garnet

Cant see local experience service from vuforia view

I setted up the thingworx and experience service locally, everything works fine but when i want to see the experiencre through vuforia view it doesnt work.

 

i made a docs to show all the config and situations.

 

Experience Service - Windows - Documentos de Google

 

Please @RolandRaytchev help

 

Also i attached android txt log file

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Ok, finally i got it working with:

- Checking all permissions to es-public-access user in Thingworx

- Allowing self signed certifies in vuforia studio project (vuforia studio project -> info -> allow self signed)

- Experience service set to local ip of experience service running pc

 

Thank you very much for the patience, gonna check TLS also but in the future. 

View solution in original post

7 REPLIES 7

Hi @II_9204674,

the first thing you need to check if the experience is visible for the mobile device. Possibly you can check in a browser on the mobile device 

<expereinceService URL or UP>:2019/ExperienceService/ping

This should output simple OK

Also the TWX should be visible - e.g. you should be open to login there form mobile device.

Because when URLs are not visible it could not work .

When it is not visible try to connect to the same WLAN where the server is visible

When the Experience Service and TWX is visible - in this case you can check 

- make you experience as public and publish ( Studio UI - INFO>access)

-set the Allow self-signed certificate if you server uses such

- on the mobile device you can set the URL to point to your ES 

- and , please, check the following points (to ensure that TWX could be accessed) :

http://support.ptc.com/help/vuforia/studio/en/#page/Studio_Help_Center%2FAnonymousAccess.html%23

http://support.ptc.com/help/vuforia/studio/en/#page/Studio_Help_Center%2FGrantUserPermissions.html%23

 

HI i reviewed everything you said.
https://docs.google.com/document/d/e/2PACX-1vScF_rSPrZjnNE3brEyyQ7mSAz77zIEfImYiGNPoVV_JVCh0TA8ho7H7PDB1MBDionV_aJ_h0i_KXFo/pub you can check the thingworx permissions point.

 

twx and experience service screenshot from device attached to this reply.

 

- make you experience... -> yes it is public and publishes well

-set the Allow self-signed certificate ... -> where should i achieve this? this is the only missing point

- on the mobile device you can set the ... -> done but no visible changes

- and , please, check the following... -> i checked everything and updated in the docs with screenshots, can you make a list of which services/ runtime permissions do i need?

 

I really hope you can help me to get this working, very greatful for the help. Thanks, waiting for the answer.

postgres 10 experience service 9.4 thingworx fundation 9.4 Vuforia-Studio-Windows-9-4-0 (800 kb) UNTIL THINGWORX: Thingworx IoT Installation with PostgreSQL - YouTube https://community.ptc.com/t5/forums/editpage/board-id/studio/message-id/11118 EXPERIENCE SERVICE esto crea un fichero .bin dentro ...

I did not see info about the pont

on Browser on mobile device calling a ping

<expereinceService URL or UP>:2019/ExperienceService/ping

Is there a OK returned? Example Chrom from Android:

Screenshot_20220725-154714_Chrome.jpg

When it is not visible all others settings does not make sense. If the server is not visible on you mobile device  the most important thing is to see why it is not visible. You can try with the IP address  instead of the URL - possibly the domain of your server is not resolved on the mobile device

Yes i attached the screenshots in the last reply. 
Btw: 

II_9204674_0-1658762560674.png

II_9204674_1-1658762571467.png

II_9204674_2-1658762581617.png

 

Thanks for the response

 

Thanks, gonna take it a look. But this throws me a question, the support articles points to Android client side certificates. But i also need to publish for iOs devices and Hololens 2 devices. Does local installation of experience service doesnt support that? And also, i specified to NOT use TLS in experience service installation, do i need to reinstall it?

Ok, finally i got it working with:

- Checking all permissions to es-public-access user in Thingworx

- Allowing self signed certifies in vuforia studio project (vuforia studio project -> info -> allow self signed)

- Experience service set to local ip of experience service running pc

 

Thank you very much for the patience, gonna check TLS also but in the future. 

Top Tags