cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Configure for Vuforia Studio does not work

SOLVED
Participant

Configure for Vuforia Studio does not work

Hello

 

We want to test Vuforia Studio in our company but we are not able to "configure" it.

--> see attached screenshot

The credentials which I use at the window "Configure Vuforia Studio" are correct.

 

Logfile:

 

[2019-08-06T13:59:53.359Z] error: [twx-studio:auto_configure] undefined GET https://trial.studio.vuforia.com/api/v1/service_details Unable to retrieve service details. Request failed. { Error: connect ETIMEDOUT 3.222.121.221:443
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1097:14)
errno: 'ETIMEDOUT',
code: 'ETIMEDOUT',
syscall: 'connect',
address: '3.222.121.221',
port: 443 }
[2019-08-06T13:59:53.360Z] error: [twx-studio:index] unhandledRejection Unable to retrieve service details. Request failed.
GET /api/autoConfigure 500 22017.778 ms - 35

 

I also tried to add our Proxy in the settings. (Example: http://1.1.1.1:8080) However it still doesn't work. If I add the proxy with http the following error occurs in the logfile:

 

[2019-08-06T14:10:39.391Z] error: [twx-studio:auto_configure] undefined GET https://trial.studio.vuforia.com/api/v1/service_details Unable to retrieve service details. Request failed. { Error: self signed certificate in certificate chain
at TLSSocket.onConnectSecure (_tls_wrap.js:1051:34)
at TLSSocket.emit (events.js:189:13)
at TLSSocket.EventEmitter.emit (domain.js:441:20)
at TLSSocket._finishInit (_tls_wrap.js:633:8) code: 'SELF_SIGNED_CERT_IN_CHAIN' }
[2019-08-06T14:10:39.392Z] error: [twx-studio:index] unhandledRejection Unable to retrieve service details. Request failed.
GET /api/autoConfigure 500 1394.516 ms - 35

 

If I add the proxy with https the following error appears in the logfile:

 

[2019-08-06T14:12:05.680Z] error: [twx-studio:auto_configure] undefined GET https://trial.studio.vuforia.com/api/v1/service_details Unable to retrieve service details. Request failed. { Error: tunneling socket could not be established, cause=write EPROTO 12700:error:1408F10BSmiley FrustratedSL routines:ssl3_get_record:wrong version number:c:\ws\deps\openssl\openssl\ssl\record\ssl3_record.c:252:

at ClientRequest.onError (C:\Users\catarino_d\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\node_modules\tunnel-agent\index.js:177:17)
at Object.onceWrapper (events.js:277:13)
at ClientRequest.emit (events.js:189:13)
at ClientRequest.EventEmitter.emit (domain.js:441:20)
at TLSSocket.socketErrorListener (_http_client.js:392:9)
at TLSSocket.emit (events.js:189:13)
at TLSSocket.EventEmitter.emit (domain.js:441:20)
at onwriteError (_stream_writable.js:431:12)
at onwrite (_stream_writable.js:456:5)
at _destroy (internal/streams/destroy.js:40:7) code: 'ECONNRESET' }
[2019-08-06T14:12:05.681Z] error: [twx-studio:index] unhandledRejection Unable to retrieve service details. Request failed.
GET /api/autoConfigure 500 7.316 ms - 35

 

Can somebody help us? Is the format of proxy configuration correct?

 

Thank you and best regards

David

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Configure for Vuforia Studio does not work

Thanks for all the suggestions.

It turned out that the connection to the proxy-server was correct but the proxy also needs to have the domain vuforia.io whitelisted.

6 REPLIES 6

Re: Configure for Vuforia Studio does not work

Hi @BCAG_David ,

Please review the below knowledge article for Vuforia Studio failed connection issues:

 

Vuforia Studio failed connection issues

Re: Configure for Vuforia Studio does not work

Thank you for the knowledge article.

I discussed this with our network team and it seems there is something with the proxy.

Now we need to know how we have to fill in the proxy server in the settings of Vuforia Studio.

 

Is it just the IP-Address with port e.g. 1.1.1.1:8080?

Or is there something additional to add?

Re: Configure for Vuforia Studio does not work

Hi @BCAG_David ,

Yes, please specify the proxy server url in the below format. Also, if there is a username and password set for the proxy server, these credentials should also be entered in the settings dialog box for Proxy User and Proxy Password fields

 

http://[yourProxyServer]:[port]

Re: Configure for Vuforia Studio does not work

Thanks for your answer. I still can't connect altough I tried this format and a lot of others.. strange..

Re: Configure for Vuforia Studio does not work

Could you please try the auto configure option in public/home network and see if it works. If the issue is observed in the home network too please share the studio log file for tracking the issue.

Re: Configure for Vuforia Studio does not work

Thanks for all the suggestions.

It turned out that the connection to the proxy-server was correct but the proxy also needs to have the domain vuforia.io whitelisted.