cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo Illustrate Sequence out of sync in ThingWorx Studio

Highlighted
Participant

Creo Illustrate Sequence out of sync in ThingWorx Studio

I have created a sequence of steps in Creo Illustrate. When previewing the sequence in Creo Illustrate the steps are displayed correctly (timing of each effect and transform plays as configured) , however, the same sequence in ThingWorx studio appears to be out of sync. Some parts move before others even though they are configured to move together. It appears as if the parts that have additional effects do not transform until the effect has completed, example, the part changes color first and only once the color change is complete then it moves, even though the sequence is configured to move at the same time as the color change.

Has anyone else seen this behavior. Any tips on how to solve or avoid this issue?

8 REPLIES 8

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

Adam Cunnington​: Could you please confirm the ThingWorx Studio and Creo Illustrate version. Is it possible to share the sequence file to reproduce the behavior at our end.

-Durgesh

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

I am running ThingWorx Studio ver 1.12 and Creo Illustrate 3.0 M030.

I managed to ‘resolve’ this issue by splitting the Effects and Transform actions into separate steps. I’m not sure if this is expected behavior or a bug in the versions I am running, but for now it works, even if it takes a bit longer to create the sequence. 

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

Hello,

I encountered on similar issue when I was using many model items and one of them was modified (I changed occurrence or position).

Try to use just a model, without model items in another View.

Regards,

Adam

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

Hej,

moving model-items is not a bug, if you change the occurence ID but not the xyz it overwrite the xyz of the former new occurence id with the old xyz coordinates.

That's why it moves around.

Adam, are you using the "Thingview" option inside the settings of thingworx view?

Thanks

Martin

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

Martin Wassmann​, now you need to specify which Adam you are asking now

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

I adressed Mr Cunnington, as your (Mr Macierzynski) model-item issue is answered by my last comment .

:-) Martin

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

Hi Martin,

Yes, the "Thingview" option is enabled in ThingWorx View. What does it do? Should I disable it?

Thanks,

Adam

Re: Creo Illustrate Sequence out of sync in ThingWorx Studio

thingview enables the creo rendering instead of webgl rendering.

Could you take a small video of your issue? Or can you share your c3di file with us please?

Thanks

Martin