cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

HoloLens problems with Textures in 8.4.1

SOLVED

HoloLens problems with Textures in 8.4.1

Hi All,

 

I encountered a problem with the latest version of the View app on HoloLens after the update to 8.4.1 came late last week.

 

I had an experience created that used a textured model created from an FBX file.  The experience was working fine on the HoloLens using View 8.4.0, but after the update to 8.4.1, the view app crashes out when loading up the model Smiley Sad.  I had to create a new version of the experience that doesn't have any textures and that loads up fine.

 

This happened on 3 different HoloLens's all running the latest version of Windows and 2 of them have been recently reset with nothing on them apart from the View app.

 

It's not a memory issue as the performance graph from the device portal shows.  You can see the the loading, and then the plateau when the app crashes and the drop when it exits out of view which is still way below the memory limit:

view_crash_01.png

 

It's not a global problem, as I have other experiences with textures that load up OK.  Attached are the QR codes for the two versions of the experience - with and without textures.  Unfortunately, I can't go back to the older version of the View app to try again. 

 

 @tmccombie  or @RolandRaytchev  is this something that R&D can look at as I believe it's a bug that has come in to 8.4.1.

 

Many thanks,

 

Allan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HoloLens problems with Textures in 8.4.1

Well 8.4.3 was released and I'm very pleased to see that the problem has now been fixed.

 

8.4.0 - My model with textures worked Smiley Happy

8.4.1 - My model with textures crashed View Smiley Sad

8.4.2 - Textures support for HoloLens removed completely Smiley Frustrated

8.4.3 - Textures back and my model with textures works Smiley Very Happy

 

Thanks @RolandRaytchev for your help with this.

16 REPLIES 16

Re: HoloLens problems with Textures in 8.4.1

Hi @AllanThompson ,

 

thanks for reporting this issue! I did fast check and did not find related issue in the PTC database. (key words: HoloLens Texture ) - so there are  some issues but not related to a different behavior between 8.4.0 and 8.4.1

I will test today or tomorrow  projects with texture coming form Creo Parametric so will try to reproduce the issue. In case that issue is not reproducible I will need your assistance to provide some model or project to reproduce the issue... but as mention I need to test first if this is a general issue with textures in the new release  

Re: HoloLens problems with Textures in 8.4.1

so tested the 2 QR codes  GT_HoloLens_shareQR.png  - here could reproduce the chrash of the vuforia view on the Hololens

the other QR code GT_HoloLens_No_Textures_shareQR - works fine  - but I see that this model seem to be complex. 

I have  Vuforia view 8.4.1 build  197. What was the datecode where are able to load the project QR code GT_HoloLens_No_Textures_shareQR ?

Seems to be there are  peak of the memory and network usage but I was observed  also such behavior when I am testing features which are working fine.

2019-03-19_11-52-06.gif

 

Could you reproduce the issue also with models having texture with less complexity?

Re: HoloLens problems with Textures in 8.4.1

Hi Roland,

 

Unfortunately, I can't tell you the exact build version of View that I was running that worked with the textured experience, but it's the version that was available on Wednesday last week from the Windows Store as I had to install it on two of the three HoloLenses that I was using for the first time on Wednesday.  On Friday morning my time, the new version was available, and I updated the third HoloLens with this version and started having the problem.  Then on Saturday the other two must have updated automatically (I don't own them or have them now) as they also started having the problem.

 

I've tested some other models that use textures and these are working fine.

 

While I agree that it's a relatively complex model for the HoloLens, the issue is that the experience was working fine in the 8.4.0 version of View and then after updating to 8.4.1 - something that unfortunately you can't control on a Developer edition of the HoloLens, the same experience crashes out every time when loading.  And looking at the memory trace on mine, it crashes out before it even maxes out the RAM usage.  Maybe it tries to load the textures and it fails as there's not enough available RAM?

 

Regards,

 

Allan

Re: HoloLens problems with Textures in 8.4.1

Hi Allan,

 

I reported today the issue to internal development group and just received the message:

"I was able to replicate the error in the released build.  The issue has already been identified and resolved.  It will be in the next release."

So according it , issue should be solved in the next release. Please , let me know it you can verify the solution (hope next month). 

Thank you!

Re: HoloLens problems with Textures in 8.4.1

Thank Roland.

 

I see that 8.4.2 is scheduled for release on 11 April, so I'll check that the experience is working OK once I get the new version installed.

 

Cheers,

 

Allan

Re: HoloLens problems with Textures in 8.4.1

So 8.4.2 has been released and I've updated the View app on my HoloLens and the Studio software on my laptop.  Very disappointingly, it looks like textures don't work at all on the HoloLens now Smiley Sad 

 

I tried a few different experiences and they all have this issue.  I tried republishing them with the updated version of Studio - still no textures.  I also created a new experience - still no textures.

 

And of course now that I've updated my app to 8.4.2, I can't go back to 8.4.1.

 

Not happy Jan.

Re: HoloLens problems with Textures in 8.4.1

Hi @AllanThompson,

I am sorry for the inconvinience but this was statement form dev team that this should work now. I did send the model for testing and verifying. So will reopen the ticket. 

Re: HoloLens problems with Textures in 8.4.1

Hi Allan,

now I did check the thicket and this was in the original report:

2019-04-12_13-09-00.gif

 

So I tested with Vuforia View 8.4.2 on HoloLens and it was working - no crash but without texture --- means texture is removed - is this what was your observations... sorry --- will wait now for feedback if no feedback until next few days will open a new issue.

One addtional quesiton- could you provide,please,  a picture of an area of a model where we can expect the display of the texture?

I think , now in preview mode I was able to see the display dashboard / instuments  panel- and  navigation , radio panels   etc. 

Highlighted

Re: HoloLens problems with Textures in 8.4.1

Hi Roland,

 

I've got a simple experience that I've used in the past to test if textures are working on the HoloLens.  

 

Here's what I see in the preview in Studio:

 

dinosuar_project.png

 

 

 

 

 

 

 

 

And here's what I see looking at the published experience:

 

20190415_094908_HoloLens.jpg

 

You can just make out some of the details in the screenshot.  The base model colour is black, so it doesn't come through really great.

 

Here's the QR code for the project:

 

Dino_HoloLens_shareQR.png

 

Any model that I use that has any textures in it can be used and the textures won't display on the HoloLens.

 

Back in 2017 textures weren't supported, but that did get fixed at some point as I posted in this thread.