cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem viewing 3D-Buttons on Hololens

Participant

Problem viewing 3D-Buttons on Hololens

Hello everyone!
I was creating an AR-project for Hololens (1st gen), where an Air tap on a 3D- Button should trigger some javascripts and start a sequence.

While on a PC-preview the project was running flawless, during the real-case with Hololens, the buttons didn't appear.

 

Did someone experience this kind of a problem and eventually knows a solution?

Here's how the buttons look like in the designer-ui and on the preview

4 REPLIES 4
Highlighted

Re: Problem viewing 3D-Buttons on Hololens

It looks like you have some other widget controlling the Visible property of the button. Is it possible that whatever is supposed to make the button visible is not happening in the Hololens view?

 

As a test, you could try making the buttons always visible (remove the binding to the Visible property), and see if they appear in the Hololens experience. If that works, then it's something that's stopping the binding from working the way you expect.

Highlighted

Re: Problem viewing 3D-Buttons on Hololens

Hello Clay,


thank you for your suggestion! Tried it out. Unfortunately, it didn't solve the issue. In fact, I've noticed that some models, which should appear during animation, are also visible only in the browser preview. Seems to be a bug of some sort.

Highlighted

Re: Problem viewing 3D-Buttons on Hololens

Hi @sshevliakov ,

 

I tested it in the current release /studio and view / but could not indetify any issue there. 3d buttons seem to work fine on the HoloLens 1 :

 

2019-12-10_12-04-07.gif

How did you define the 3d button. Did you use any css? May be first try only using colors without styles.

Highlighted

Re: Problem viewing 3D-Buttons on Hololens

Thank you for responses @RolandRaytchev @ClayHelberg !

Ironically, the buttons are now working on the device, despite I didn't change anything (neither in experiences, nor in the Hololens-settings).

Seems to be either a bug in vuforia view or some troubles caused by slow internet connection.

Announcements
Join an
AR Working Group!

Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection