cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with playing sequences on HoloLens

AllanThompson
16-Pearl

Problems with playing sequences on HoloLens

Hi All,

I'm experiencing a problem with getting a sequence to play in a HoloLens experience.

I've created a simple 4 step sequence in the PVZ file and I've tried two different things to get it to work:

  • Bind the doubletap application event to the Play All service of the model
  • Create a 3D image and bind the click event to the Play service of the model

In both cases the preview of the experience works correctly, but when I publish the experience and try to get the sequence to play, nothing happens.

Anyone else having this problem?

Many thanks,

Allan

36 REPLIES 36

For me, the nice-to-have would be the inclusion of annotation and tools (as mentioned) that are created in Illustrate to populate in HoloLens when viewing sequences; seems the fix is only "half-fixed"?

 

Regardless, any progress is great. 

 

Brian

Hi all,

 

tried Hololens today, one really simple sequence made in Illustrate 5.0 and in Hololens nothing played 😞

 

Regards,

Bojan

Raphael08
5-Regular Member
(To:bgračnar)

Hi,
1. check version of Studio and Vuforia view in your Hololens

2. We having same issues here (we can not figure out the reasons), but what help ist to creat a new projekt in Illustrate and do the animations again...than it works.....(sometimes )

Hi Raphael,

 

Studio is updating automatically (8.2.3) and on hololes View was updated 2 weeks ago (83.3.108.0)

I installed also Illustrate 4.2, preview works as it should, on hololes nothing.. 😕 

 

Regards,

Bojan

Raphael08
5-Regular Member
(To:bgračnar)

Hi Bojan,

 

here we have it 😉  Studio is not updating automatically.....

There is 8.3.3 available

Hi Raphael,

 

what? it did before.. what changed? Smiley Surprised Smiley Embarassed

 

And thank you, installed maunally new version and it is working now.. (some basic movement steps & color change made in Illustrate 4.2)

So now that 8.3.6 has been released, I've done some more testing on this and I've found the following updates for a model that has a sequence defined:

  1. setting display = false doesn't work
  2. setting forceHidden = true doesn't work
  3. setting opacity works - fixed!
  4. changing the sequence via JS works - fixed!
  5. changing the model source to a different PVZ works - fixed!

My workaround of using an application parameter to control opacity still works, so I don't have to redo that which is nice, but now I would just set the opacity of the widget directly.

 

I didn't expect that item 1 would  change as this is how it's always been, so it looks like it's only forceHidden that doesn't work on the HoloLens.

 

Sorry @RolandRaytchev, I haven't checked your issue of setting the sequence step via JS.  Hopefully this works now too.

 

Announcements

Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection