cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Publishing Project on Vuforia Studio doesn't work

Highlighted
Contributor

Publishing Project on Vuforia Studio doesn't work

Hello everyone

I can not publish my Project on Vuforia Studio and I'm having this Error "Internal Server Error"! Can you please help me!? Thank you

I  attached the log file for more informations

 

PS:

I already checked node.exe through the resmon.exe and it is set on "allowed, no restrictions"

I also tried publishing after disabling all Firewalls and I still get the same problem.

 

2 REPLIES 2
Highlighted

Re: Publishing Project on Vuforia Studio doesn't work

I'm seeing this in the log file:

[2020-03-17T07:34:23.744Z] error: [twx-studio:auth:oauthHandler] Error making request for oauth configClient network socket disconnected before secure TLS connection was established Error: Client network socket disconnected before secure TLS connection was established
    at connResetException (internal/errors.js:604:14)
    at TLSSocket.onConnectEnd (_tls_wrap.js:1513:19)
    at Object.onceWrapper (events.js:417:28)
    at TLSSocket.emit (events.js:323:22)
    at TLSSocket.EventEmitter.emit (domain.js:482:12)
    at endReadableNT (_stream_readable.js:1204:12)
    at processTicksAndRejections (internal/process/task_queues.js:84:21) {
  code: 'ECONNRESET',
  path: null,
  host: '66afcd555db4f348.studio-trial.vuforia.io',
  port: 443,
  localAddress: undefined
}

 

 

Looks like this may be a proxy issue on your network. Are you trying to publish on your corporate network? If there is a proxy on your network, you'll need to configure Studio to use the proxy as it does not inherit the browser proxy settings. See this Tech Tip for configuring the proxy: https://community.ptc.com/t5/Vuforia-Studio-and-Chalk-Tech/How-to-solve-Proxy-Script-based-configura...

 

Another thing you can try is accessing your assigned Experience Service directly in your browser. Based on your log files that would be this: https://66afcd555db4f348.studio-trial.vuforia.io/ExperienceService/ui. You should be prompted for your credentials. If this works, but you can't validate/publish within Studio, then there is most likely a proxy causing issues. 

 

 

Highlighted

Re: Publishing Project on Vuforia Studio doesn't work

I'm trying to publish from my corporate network. As I tried to publish from a private network it worked.

I've tried to configure the proxy of my corporate network following the steps in the Tech Tip and the test shows "No proxy sttings for this mode" (You can check the Screenshot below).

I asked my supervisor and he told me there is no proxy used in our department.

Announcements
Join an
AR Working Group!

Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection