cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Vuforia View crashes ob Hololens

Highlighted
Regular Member

Vuforia View crashes ob Hololens

I created an experience on Vuforia Studio using model target detection and it the detection works fine. That I give more information in the experience, so more pictures and models and now when I start the experience on the Hololens the App is crashing, sometimes just a few seconds after start and sometimes while detection. I tried to split the experience in two parts, and so both work fine. But together not. Maybe the project is to big? Is there an limit on project size for Hololens? I also reconigze that my project can't get bigger than 5 Mbit when i save. I also tried using a Vumark detection instead of the model target detection. But get the same problem. I'm using an test experience service. I also checked if the problem is the internet, but it seems fast enough.

 

Hope someone can help me

6 REPLIES 6
Highlighted

Re: Vuforia View crashes ob Hololens

Hi @Milliau,

5 MB (project size) should not lead to a problem . I saw projects which are  > 20 MB size and are working fine.

What is the  version of the HoloLens viewer?  I think there is issue with the latest Vuforia View 8.4.1 with textures. Do you have textures in your 3d  model?

Re: Vuforia View crashes ob Hololens

I updated the Vuforia View, because I thought that this can solve to problem. But doesn't help. No there is no textures in the model. I also tried it without the model and get the same problem.

Highlighted

Re: Vuforia View crashes ob Hololens

I found a Log on the Hololens and there are this errors:

2019-03-26T12:08:47.864+01:00 [Error] MainPage - Navigating Starting for [null]
2019-03-26T12:08:47.864+01:00 [Error] MainPage - Clearing the ms-local-stream resolver.

But how can i solve them?

 

 

Highlighted

Re: Vuforia View crashes ob Hololens

Hi @Milliau ,

I do not think that the message is sufficient enough to find what could be the problem

So the following question

- is the preview behavior ok ! If not then you have to debug it in the console (Strg-Shift-I)

-In case that is ok  we I  need to check the project itself to find what is the problem. So for example we can :

remove the model , or make it more simple  (if possible) to see if the problem is a model complexity issue or is caused by some widget which is not directly related to the model or by some scripting

or you can create a new project where the only widget is a 3d model widget and see if it is displayed ok and e.g. if you can play any sequences (by adding only a button for playing). If this is working fine, then the issue is not model related and we need to check the project design

Highlighted

Re: Vuforia View crashes ob Hololens

 

- is the preview behavior ok ! If not then you have to debug it in the console (Strg-Shift-I)

 

yes in the preview it works fine

 

-In case that is ok  we I  need to check the project itself to find what is the problem. So for example we can :

remove the model , or make it more simple  (if possible) to see if the problem is a model complexity issue or is caused by some widget which is not directly related to the model or by some scripting

 

I tried this allready and found out that if I split the project in two parts both works but together it doesn't work, that's why I think that the is a problem with the size or something

 

Maybe the problem is that there are two many model because I use 20 model, mostly the same model on different positions.

Highlighted

Re: Vuforia View crashes ob Hololens

Means you use the same model (same *pvz file) in 20 different model widgets?

if yes , are they visible all the same time? May be, we can move some models dynamically on a new position. We can check e.g. and eye direction vector… (is of course not so easy to implement)

- is the pvz file optimized /Cad Optimizer (for example low will required less system resources)

-is possible to simplify the pvz file , means to check if there are some components (inner comp) which are not relevant and could be removed.

- is there a particular component (behind is a part)which contains bad geometry - means you can get a problem with only with couple of few such models.

- In case that the same model is used in different model widget many times – so we can try to make one assembly and use model items for the different models….  

Ok this are some points .. but to be  able further to assist  I need to check the real project

Announcements
Join an
AR Working Group!

Topics available:
AR/VR for Data Optimization AR/VR for Security and Control AR/VR for Inspection