cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

White page in the editor and global error starting preview

EdgarPironti
7-Bedrock

White page in the editor and global error starting preview

Not sure if this is related to an update of Vuforia Studio Editor:
When opening some projects during the loading process, something goes wrong and while the 3D viewport in the editor is loading, suddenly it becomes completely white. Also, the hierarchy results as empty.

 

When this happens, I don't see any error in the log, but if I try to launch the preview I receive a Global error and in the log, I read:

 

 

 

Error: Invalid glob argument: 
    at Gulp.src (C:\Users\epironti\AppData\Roaming\VuforiaStudio\studio-download.vuforia.io\node_modules\vinyl-fs\lib\src\index.js:20:11)
    at C:\Users\epironti\Documents\VuforiaStudio\Projects\Prometeon_Custom_Demo\gulp-shared.js:532:12
    at new Promise (<anonymous>)
    at C:\Users\epironti\Documents\VuforiaStudio\Projects\Prometeon_Custom_Demo\gulp-shared.js:523:12
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)

 

 

 

 

I've already tried to re-install Studio and removing some projects that I thought were causing the issue. But didn't solve completely.

 

Thanks for your help!
Edgar 

6 REPLIES 6

What browser are you using to run Studio? 

Google Chrome Version 85.0.4183.102 (Official Build) (64-bit)

Eventually running the Editor on Edge I don't have the same problem. I wonder why I'm the only one experiencing this since I cleaned Google Chrome cache and did a clean re-install of Vuforia Studio.

 

Other errors I got from Studio:

[2020-09-19T10:51:58.365Z] error: [twx-studio:proxy] Proxy error getaddrinfo ENOTFOUND pp-200902075960.portal.ptc.io Error: getaddrinfo ENOTFOUND pp-200902075960.portal.ptc.io
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26) {
  errno: 'ENOTFOUND',
  code: 'ENOTFOUND',
  syscall: 'getaddrinfo',
  hostname: 'pp-200902075960.portal.ptc.io'
} null 200
[2020-09-19T10:51:58.365Z] error: [twx-studio:proxy] twx server proxy error...
[2020-09-19T10:51:58.365Z] error: [twx-studio:proxy] Error: getaddrinfo ENOTFOUND pp-200902075960.portal.ptc.io
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26)
GET /ExperienceService/viewcommandhost 500 1.469 ms - -
[2020-09-19T10:51:59.354Z] error: [twx-studio:versionCheck] Could not find latest version:  getaddrinfo ENOTFOUND studio-download.vuforia.io Error: getaddrinfo ENOTFOUND studio-download.vuforia.io
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26) {
  errno: 'ENOTFOUND',
  code: 'ENOTFOUND',
  syscall: 'getaddrinfo',
  hostname: 'studio-download.vuforia.io'
}
[2020-09-19T10:51:59.354Z] error: [twx-studio:versionCheck] could not determine version getaddrinfo ENOTFOUND studio-download.vuforia.io Error: getaddrinfo ENOTFOUND studio-download.vuforia.io
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26) {
  errno: 'ENOTFOUND',
  code: 'ENOTFOUND',
  syscall: 'getaddrinfo',
  hostname: 'studio-download.vuforia.io'
}
GET /api/version/check 500 3.953 ms - 27

 

And from Google Chrome Console

 

libthingview_wasm.js:1 Warning: Session::GetParent has been deprecated. Use View::GetParent
put_char @ libthingview_wasm.js:1
write @ libthingview_wasm.js:1
write @ libthingview_wasm.js:1
doWritev @ libthingview_wasm.js:1
_fd_write @ libthingview_wasm.js:1
(anonymous) @ libthingview_wasm.wasm:0x479807
(anonymous) @ libthingview_wasm.wasm:0xd7051
(anonymous) @ libthingview_wasm.wasm:0x3cf0e
(anonymous) @ libthingview_wasm.wasm:0x4720c8
(anonymous) @ libthingview_wasm.wasm:0x474c01
(anonymous) @ libthingview_wasm.wasm:0x1998c3
Ri @ libthingview_wasm.wasm:0x274212
invoke_iii @ libthingview_wasm.js:1
(anonymous) @ libthingview_wasm.wasm:0x3b2d8
(anonymous) @ libthingview_wasm.wasm:0x24d61
(anonymous) @ libthingview_wasm.wasm:0x429719
(anonymous) @ libthingview_wasm.wasm:0x14477c
Ri @ libthingview_wasm.wasm:0x274212
dynCall_iii_1558 @ VM13622:4
Session$GetCanvasName @ VM17269:8
_deleteSession @ thingview.js:418
DeleteSession @ thingview.js:217
ctrl.beforeDestroy @ twx-mobile-widgets-3d-ng.js:3060
beforeDestroy @ system-widget-extensions.js:4268
ctrl.remove @ common-include.js:11495
(anonymous) @ common-include.js:11490
each @ jquery.min.js:2
each @ jquery.min.js:2
ctrl.remove @ common-include.js:11487
ctrl.removeWidget @ common-include.js:12150
(anonymous) @ common-include.js:12052
$eval @ angular.min.js:154
$apply @ angular.min.js:155
$scope.handleRemovedWidget @ common-include.js:12051
postMessage (async)
(anonymous) @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
n @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
(anonymous) @ Grammarly.js:2
Show 4 more frames
libthingview_wasm.js:1 Uncaught TypeError: Cannot read property 'addEventListener' of null
    at Object.registerOrRemoveHandler (libthingview_wasm.js:1)
    at __registerMouseEventCallback (libthingview_wasm.js:1)
    at _emscripten_set_mousedown_callback_on_thread (libthingview_wasm.js:1)
    at :3000/extensions/libthingview_wasm.wasm:wasm-function[35736]:0xb6f7f8
    at :3000/extensions/libthingview_wasm.wasm:wasm-function[35740]:0xb70337
    at :3000/extensions/libthingview_wasm.wasm:wasm-function[35743]:0xb70653
    at Si (:3000/extensions/libthingview_wasm.wasm:wasm-function[11714]:0x44ec49)
    at Object.mouseEventHandlerFunc [as handlerFunc] (libthingview_wasm.js:1)
    at HTMLDocument.jsEventHandler (libthingview_wasm.js:1)

Not sure if this is a coincidence, but disabling Grammarly Chrome extension, after a quick test, seems that Vuforia Studio is running again on Google Chrome. 

Strangely enough though, the beginning of this problem doesn't correspond to the moment I installed Grammarly.

Hmm. That is definitely strange. The errors in the Studio log seem to indicate Studio is having issues connecting to the portal. This is normally due to a proxy or other network restrictions and shouldn't affect the 3D space display. I have seen this issue once before, and it had to do with WebGL being disabled. Specifically, Disable3DAPIs under http://chrome//policy/

 

An interesting test would be to enable Grammarly in Chrome again and see if WebGL still works. You can confirm this by going to https://get.webgl.org/. 

I had the same issue (reported on the internal Slack channel as well) and after Edgar pointed me to this post I disabled Grammarly and it seemed to have solved the issue. In my case, when I opened a project it suddenly deleted all my items in the tree (view's JSON file became empty). Returning back to the Studio main page without saving and re-opening the project helped, but it was very annoying.

Thanks for the tip on this!

Top Tags