cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Java 1.7 support for Windchill 9.1 and 10.0 required

Java 1.7 support for Windchill 9.1 and 10.0 required

An enterprise sites customer like Volkswagen and Liebherr will deploy Java 1.7 on the clients centralized as soon as Java 1.6 gets obsolete / out of support.

Support for Java 1.7 for Windchill 9.1 and 10.0 is therefore absolutely needed. Please make a plan how for certify Java 1.7 and how to deal with this situation.

6 Comments
Regular Member

The same for some ABB business areas working with Windchill!

Newbie

Homeland Security has issued an advisory on disabling Java.

And have notified all DOE/DOD facilities on blocking Java 6.

This is turning into a CRITICAL ISSUE.

Participant

As a start, PTC should rewrite the process manager and team template administrator in html/javascript.  I just finished writing our own html process manager (our users use the process manager frequently).  I'm sure it's not 100%, but if I can do it in a week, I'm sure PTC can release something.

Newbie

Because of the security gaps in any revisions other than the latest Java revision, our Windchill experience has become quite difficult.  My estimation of priority is CRITICAL, given the risk that we will not be able to run Windchill applications.

Newbie

Java 1.7 is no longer supported by Oracle.  Windchill 9.1 and 10.0 are both now in extended support, in which PTC does not normally introduce new platform support.

Community Manager
Status changed to: No Plans to Implement