cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Support for Open Source Java for Windchill/FlexPLM

Support for Open Source Java for Windchill/FlexPLM

 

Starting January 2019, you need to plan to obtain and install Java as a prerequisite for installing or re-installing the PTC products that rely on Java and need to secure your own support contract with Oracle for updates to Java including security patches.

 

Providing support for Oracle Java and Open Source Java allows the customer to be more flexible in their solutions and would be a great benefit to everyone.

 

1 Comment
Level 18

As I understand it, the JDK will continue to remain available for download with any Windchill versions that were released prior to January 1st of this year.  After that point you will need to get the JDK (and client JRE if necessary) from somewhere else.  That could be the paid version (if you need constant security updates) or possibly even other free and/or open source versions (use at your own risk.)