cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

WGM Server should accept previous client versions

WGM Server should accept previous client versions

When upgrading to a new version of Windchill Workgroup Manager every client machine needs to be updated. It would be very beneficial if there were some backward compatibility for the clients. For example, if a CPS or MOR is released it would be very valuable for it to support the previous version(s) of the WGM client. Currently our procedure is to upgrade the Windchill server, wait for successful completion of an upgrade, and then inform the CAD administrators to update all of their clients globally. The issue is that we usually don't finish and upgrade or patch until Sunday afternoon and it is already Monday morning in China. This gives the CAD administrators VERY limited amount of time to upgrade the CAD clients. It is also difficult because many of the global CAD clients that are administered remotely are turned off on weekends. This causes the CAD designer to lose many hours of work waiting for the CAD administrator to upgrade their systems. If the Server accepted previous version of the client with a soft warning the CAD administrators would be able to update all the systems without interrupting the work of the designers .

2 Comments
Amethyst

Hi Chris,

 

Starting from Windchill 11.0 M010, we are supporting more flexibility among Windchill servers & WWGM clients within same MOR. Request you to refer below blog & let me know, if addresses your concern..

 

Compatiblity between Windchill 11.x and Windchill Workgroup Manager 11.x

 

Regards,

Pankaj Mooteri

Product Manager - PTC

Garnet
Status changed to: Current Functionality

The url link in Pankaj's comment was correct with the correct PTC Technical Support article.