cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How to "Disable" Usage of Owner Association

Level 9

How to "Disable" Usage of Owner Association

Recently a customer asked if it were possible to disable Owner association, and instead have the system default to using Contributing Image association between WTParts and CAD Documents.  I figured there might be others interested so I thought I would post the solution, as the steps to achieve this desired behavior might not be entirely obvious. Before doing so, however, I have to give credit to my colleague, Jennifer Pierron, for providing me with these steps. Here we go…

In this case, the goal is disable Owner association for CAD assemblies and parts and display Contributing Image as the default association type in the Edit/Auto Associate UI.  You configure a set of Site preferences to accomplish this task.  I repeat - Site preferences.  These preferences cannot be set on a per-user or organization level basis. They apply across your entire installation.

First, you need to establish which attributes you want to pass from CAD Documents to WTPart via the Contributing Image association.  This can be done by setting the Site preference EPM Service Preferences > Build Service Preferences > Contributing Image Attributes to * for all attributes, or you may specify individually using a list of attribute names.  If you do not specify any attributes, then the system defaults to using an Image association instead of a Contributing Image association. In effect, the preference settings in the following figure enable Contributing Image associations in your system.

figure_1.png

Next, configure the CAD Document types for which you do not want to build structure (disallow Owner associations).  In this example we disallow the building of structure for Creo Parts and Assemblies.  To accomplish this, we add CADCOMPONENT and CADASSEMBLY to the list of types for which building structure is excluded.  This is done by editing the preference Operations > Auto Associate > Disallow Structure CAD Document Types > Creo as shown in the following figure.

figure_2.png

As a final step, If you want to allow Auto-Associate to create parts, you need to set the value of the preference Operations > Auto Associate > Create New Part to Owner and Contributing Image as shown in the following figure. The default is to allow this for Owner association types only.

figure_3.png

Once these preferences have been set, when you perform an Edit Association, you should be presented something similar to the following.

figure_4.png

I hope you found this useful.

Tags (1)
3 REPLIES 3

Re: How to "Disable" Usage of Owner Association

Step two where you add CADCOMPONENT and CADASSEMBLY to the Creo preference .. the path should say Operation>Auto Associate>Disallow Structure CAD Document Types>Creo.

Also, to change the association type for a large assembly already associated with the 'Owner' type, Add the WTParts to a workspace, Edit Association for all parts, Remove All Associations, and select OK. All WTPart will be checked out. Edit Association for all parts again and all will default to 'Contributing Image'.

Hope this helps.

Re: How to "Disable" Usage of Owner Association

Thanks for pointing out the typo.  it should be corrected now.

Highlighted

Re: How to "Disable" Usage of Owner Association

Steve - this is very good information. Thank you for posting. As a follow-up question, have you found that blanking out this preference (removing the * altogether) allows the setting "Create Content Links for Drawings=Yes' to work properly? Whenever i don't blank out CIA preference, I find that my "create content links for drawings" setting to "yes" will not work. It appears that CIA being set to * somehow disallows automatic content links for drawings during auto-associate.