cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

9.1 M050 bulk indexing problems

Newbie

9.1 M050 bulk indexing problems

We rehosted our production system (9.0 M070) to our test system and upgraded it to 9.1 M050 twice without too many problems. However, the first time bulk indexing didn't work at all. After working with PTC, we needed to two patches to finally get it to work. The second time we followed the same exact steps, including installing the patches, and thought all would be well. Not true! It's not running again. Once started using the bulk indexing tool: windchill wt.index.BulkIndexTool, the number of object processed remained at 0 for at least 24 hours. PTC had us adjust on wt.properties entry and it proceded 18072 objects and stopped. After two weeks of wrestling with PTC support, we are no further along.

Has anyone else had any issues with bulk indexing? I'm told the problem is with FAST ESP. Ideas comments?

Thanks in advance!!

8 REPLIES 8

9.1 M050 bulk indexing problems

Is it Windows? Running Microsoft Cluster?



Thanks,

Lakshman Easwaran
Stryker Orthopaedics
325 Corporate Drive
Mahwah, NJ 07430

9.1 M050 bulk indexing problems


Sorry, we are running Windows Server 2003 and it's not a cluster. The
system has 8 processors with 32 Gb memory. So it should have plenty of
horse power.

Dave

David C. Palmer
3039 Cornwallis Road, Bldg 201, L109-A
RTP, NC 27709-2195

RE: 9.1 M050 bulk indexing problems

What is the value of wt.index.BulkIndexSize? This is the number of documents it will try to process at a time. The default is 200 so if you have 100,000 documents to bulk index, you'll have 500 bulk index entries queued in the BulkIndexQueue1 and 2.

During our bulk index on 9.1 M040, I decreased the bulk index size to 50 which quadrupled the number of entries that queued up but it seemed to index documents much faster.

PTC recommended not to move this value too low because it couldput "too many" entries in the queue. How many is "too many"? Not sure...

9.1 M050 bulk indexing problems

Dave

We have been seeing similar problems with FAST ESP, what really was
annoying was our servers are all 64 bit platforms ( 3 Servers, one
dedicated to FAST) and the latest version of FAST does not run on our
server. We had to pull in a older XP box and run it on that. PTC says
that Fast is supported on all platforms that run 64 bit except Windows.
so now we are looking at REDHAT for the OS on our system.

We keep a close eye on the bulk indexing. I will have to try to cut the
default size down to see if that works.

Marc

David C Palmer wrote:
>
> Sorry, we are running Windows Server 2003 and it's not a cluster. The
> system has 8 processors with 32 Gb memory. So it should have plenty of
> horse power.
>
> Dave
>
> David C. Palmer
> 3039 Cornwallis Road, Bldg 201, L109-A
> RTP, NC 27709-2195

9.1 M050 bulk indexing problems

Would really like to hear from others on this also. One person in our group has been back and forth w/tech support for many weeks now trying to get anything close to a successful bulk index on a rehosted test system w/o much progress. The effort so far is what appears to be PTC just shooting in the dark asking us to try different things that possibly could or might work. It appears that FAST for 9.1 is nowhere near ready for actual production use on a real data set.

Super frustrating because we had it in reasonably routine use on 9.0, but haven't been able to get it working again on 9.1 - need to continue telling users that "we're working on it."

RE: 9.1 M050 bulk indexing problems

Originally, we had a problems with the speed of the bulk index. That was resolved by tweaking the BulkIndexSize in my earlier post. After we that issue was resolved, it appeared that the keyword searches stopped working once we had indexed a certain number of documents. I don't know the exact number butwe had a temp patch issued based on SPR# 1968958. Once this temp patch was installed, everything seems to be working normally. FAST is working fine for us on 9.1 M040.

We are looking to upgrade to 9.1 M050 to fix some other issues. I'll make sure I test FAST thoroughlybefore we upgrade.

9.1 M050 bulk indexing problems

We are running FAST in Windows 2008 R2 64-bit running in Microsoft
Cluster. We had issues initially due to security enhancements of
Microsoft Cluster 2008 because of which we are running FAST and
Windchill BGMS in the same node. We also applied temp patch for SPR
1968958. We also had set bulkIndexSize to 1 while debugging issue with
FAST.



FAST is running fine on 9.1 M040 and it has indexed about 4 million
objects so far.



I had to resetIndex a couple of times. I had done that when
Indexing/BulkIndexing queues will not move. FAT UI is the best place to
check whether reset index is required.





Thanks,

Lakshman Easwaran
Stryker Orthopaedics
325 Corporate Drive
Mahwah, NJ 07430

9.1 M050 bulk indexing problems


To all. Based on what I've read, it sounds like we're not the only ones
having issues with this, which is good and bad! As an update on our
situation, we finally got a PTC tech who is able to help us and at the
moment, our bulk indexing is finally running. I will attempt to create a
step-by-step of what we did and the recommended settings for all the conf
files and post it. But, I'd like for our bulk indexing to run to
completion first. At the rate it's going, that will be a couple of days.
Thanks to everyone for all the inputs. And good luck to those who dare
attempt the 9.1 M0X0 upgrade.

Dave

David C. Palmer
3039 Cornwallis Road, Bldg 201, L109-A
RTP, NC 27709-2195