cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Bulk loading soft-typed end items

Newbie

Bulk loading soft-typed end items

I am trying to bulk load a "soft typed" end item but I am getting the following error: -



Create Part Failed (301002022 1.<iteration>,YGB): Unable to create object class wt.part.WTPart.
Nested exception is: wt.util.WTPropertyVetoException: The value of "Type Definition Reference" cannot be set to null, since it is a "required" attribute.
Loader method wt.part.LoadPart.beginCreateWTPart reported a failure
No objects were imported due to the error.
Check method server output for successful completion of all loads.




I am using wt.part.LoadPart.beginCreateWTPart but should I be using wt.part.LoadPart.createProduct instead?

2 REPLIES 2

Bulk loading soft-typed end items

I thought a bit more.....maybe it is your type definition? You may be
able to do what you tried, but how did you define typedef?

BeginWTPart~create~wt.part.LoadPart.beginCreateWTPart~partName~partNumbe
r~type~source~folder~lifecycle~view~teamTemplate~lifecyclestate~typedef~
version~iteration
EndWTPart~create~wt.part.LoadPart.endCreateWTPart~publishFlag~parentCont
ainerPath

Also I attached an example of a part load.

Kevin J. Hanmann
Solution Master Architect
5417 Sports Club Run
Suffolk, VA 23435

781-370-5088 office
919-656-4255 mobile
781-707-0498 fax

-

RE: Bulk loading soft-typed end items


Hi Sam,

I am also facing same error, while crating new soft-type WTPart using java class. Can you please let me know how can I resolve this issue?

Thanks,

Avinash


In Reply to Sam Dickinson:

I am trying to bulk load a "soft typed" end item but I am getting the following error: -



Create Part Failed (301002022 1.<iteration>,YGB): Unable to create object class wt.part.WTPart.
Nested exception is: wt.util.WTPropertyVetoException: The value of "Type Definition Reference" cannot be set to null, since it is a "required" attribute.
Loader method wt.part.LoadPart.beginCreateWTPart reported a failure
No objects were imported due to the error.
Check method server output for successful completion of all loads.




I am using wt.part.LoadPart.beginCreateWTPart but should I be using wt.part.LoadPart.createProduct instead?