cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can the windchill "save as" feature be done offline and include drawing files?

mparmenteri
5-Regular Member

Can the windchill "save as" feature be done offline and include drawing files?

I need to perform a "save as" operation on a large assembly, complete with multiple sets of drawings, assemblies, and sub-assemblies. I cannot do it while connected to WindChill due to errors with pre-existing file names (Intralink allowed an override but that feature is lost in WindChill).

I know that while working offline in CREO, I can rename a top level assembly with the File - Save As command and receive the prompt to rename the rest of the parts of the assembly. I need this command to work but include the drawing attached to the top level assembly. Performing a File - Save As command on a drawing only renames the drawing and does not change anything with the rest of the files.

I think CREO has the functionality to do this because the rename command will update everything in session and on the disk, but I do not know how to tell CREO to save the entire package to a new set of names.

Thank you for any input.

1 ACCEPTED SOLUTION

Accepted Solutions

test_ren.png

The *.asm/*.prt and their corresponding *.drw must have the same name. In the example I have created test_asm.asm and a drawing with the same name. Also I have created a part test_prt.prt and a drawing with the same name. Then I have # File #SaveAS #Save_a_Copy of the test_asm.asm to test_asm_ren.asm. In the "Save A Copy" dialog I also #Action #Save_a_Copy to the part. Creo copied the asm and the prt and their drawings to the new names. (In the following picture I added "1" to the names because I have taken it afterwards and it's just for illustration...)

save_a_copy.png

View solution in original post

12 REPLIES 12

Have you set the config.pro option "rename_drawings_with_object both"? This should also copy the drawings to a new name when "saving as" from Creo.

Regards

Jan

mparmenteri
5-Regular Member
(To:JanSchmidt)

Thanks Jan,

This seemed like exactly what I was looking for. I tried updating my config file, applying it, and performing the "save as" operation on the assembly (I did check the 'Copy Drawings' box as well) but Creo only renamed the assembly file. When I attempted the "save as" operation on the drawing, it only creates a duplicate of the original drawing without touching the models.

From what I can tell, updating that entry in the config file had no effect on the "save as" operation. Is there another option I need to update in my config file?

Matt P.

test_ren.png

The *.asm/*.prt and their corresponding *.drw must have the same name. In the example I have created test_asm.asm and a drawing with the same name. Also I have created a part test_prt.prt and a drawing with the same name. Then I have # File #SaveAS #Save_a_Copy of the test_asm.asm to test_asm_ren.asm. In the "Save A Copy" dialog I also #Action #Save_a_Copy to the part. Creo copied the asm and the prt and their drawings to the new names. (In the following picture I added "1" to the names because I have taken it afterwards and it's just for illustration...)

save_a_copy.png

mparmenteri
5-Regular Member
(To:JanSchmidt)

Thank you so much for your help, Jan!

mparmenteri
5-Regular Member
(To:JanSchmidt)

I have one more question associated from your last response, Jan.

How would I go about renaming a package such as you described above, but the top level drawing (and possibly the lower level drawings) has multiple models attached to the drawing. Your example worked for the specific package that I was working on, but I know we have other, similar issues with other packages that are more complex.

You could try the "Save as" from Workspace. There is an option to update parents. It's described under "Using Workspace Save As" in the Windchill Help Center.

mparmenteri
5-Regular Member
(To:JanSchmidt)

Unfortunately, this is the crux of my original problem. When I try and "Save as" from workspace, I need to save-as in a specific number format (contract requirement). Say that assembly1 is made of parts a, b, and c. I need to rename this to 123-assembly1, 123-parta, 123-partb, and 123-partc, plus their associated drawings. This can be done easily in WindChill, unless, say, 123-partc already exists in WindChill (from a previous save as operation on another assembly that contained partc, thus it is exactly the same part). The operation fails when WindChill recognizes this and gives no option to override (ProIntralink used to allow an override, but that functionality was removed in WindChill). Ideally, we'd be able to tell WindChill that "Yes, I know this part exists, replace the conflict part with the one that is already stored in WindChill".

My rationale for posting this thread was to find a way to do my entire "save as" operation offline, thus avoiding the error. Upon reconnecting to the workspace I could run the 'update workspace' command on my problem parts to incorporate the already existing parts into the package.

Hi,

Try changing the below preference value to yes. This preference is not part of the UI.

This might help you in overriding the conflicts during saveas.

  • windchill wt.preference.SetPreferenceUtility -name saveas.replace.w.ws.content -value true

Where do we change this value?  Config.pro?

You have to execute the command from Windchill shell in server.

mparmenteri
5-Regular Member
(To:cpadmanabhuni)

Hi Chiranjeevi,

We attempted to integrate the above code as mentioned in this document:


https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS94283&art_lang=en&posno=2&q=saveas.replac...

Unfortunately, this had no impact on the overall operation. It still terminated with an non-override-able error.

Do you know of any other steps we need to take for this to take effect?

Thanks,

Matt P.

Hi Matt,

Just setting the preference does the trick for me.

May be you make sure that preference is properly loaded. If you are using cluster setup, make sure that preferene is set in all servers. Also check by  loading the preference using command line instead of from load file (That's what I did).. If you are using load file, then try loading it without any organization so that the preference is set at site level.

Announcements