cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

DTI is not working after configuring SSO , Shibboleth as RP and PingFederate as Idp

Regular Member

DTI is not working after configuring SSO , Shibboleth as RP and PingFederate as Idp

Hello,

 

I Configured Windchill for SSO configuration. Using shibboleth as Service Provider and PingFederate as Identity Provider. After SSO configuration DTI is throwing the following error.

 

 Could anyone Please help here.?

 

ThankYou,

madhu 

2 REPLIES 2

Re: DTI is not working after configuring SSO , Shibboleth as RP and PingFederate as Idp

I have the same problem on my development system.   I have not found a solution yet.

Highlighted

Re: DTI is not working after configuring SSO , Shibboleth as RP and PingFederate as Idp

Hi..

Please check if Form-Based Authentication enabled for DTI :

 

If you want to use form-based authentication with your DTI implementation, additional configuration is required.
Out-of-the-box, the DTILogin action of the connect command is defined as HTTP. In order to use form-based authentication, it must be defined as WIZARD.
This change only needs to be done once, and should be done when you are configuring the Windchill server for form-based authentication. All DTI clients implement the changes when they reconnect to the Windchill server.
 
1. Navigate to the following directory:
   <Windchill>\codebase\com\ptc\windchill\enterprise\nativeapp\msoi\client\xml
2. Locate the following files:
  • wtDesktop.xml
  • wtOffice.xml
  • wtWindows.xml
3. In each file, replace the following line:
<action serverAction="DTILogin" type="HTTP"></action>
with
<action serverAction="DTILogin" type="WIZARD"></action>
 
4. Clear DTI cache :
 
  1. Kill WTWindows.exe process
  2. Delete cache folder. - DTI cache is present at:   %AppData%\ Local\PTC\Desktop Integration\Cache\PTC\Desktop Integration\Cache
  3. Try connecting the Windchill server through DTI.
 
Hope this helps
Arshad