cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Difficulties to change search settings in wt.properties.xconf

Participant

Difficulties to change search settings in wt.properties.xconf

Hi there,

I would be enable the advanced search for empty and single wildcard (*). The Windchill documentation states that this can be done by setting the property com.ptc.windchill.enterprise.search.advancesearch.enableEmptySearch to true.

 

I am used to edit settings with the xconfmanager tool. The command

 

xconfmanager -s  com.ptc.windchill.enterpise.search.advancesearch.enableEmptySearch=true -t codebase\wt.properties -p

failed with this error message:

0 [main] ERROR com.ptc.windchill.structconf.StructConfManager - Extra unrecognized arguments: "com.ptc.windchill.enterprise.search.advancesearch.enableEmptySearch=trueá -t"," codebase\wt.properties -p"

So my question is: How do I properly set this option in wt.properties.xconf?

 

And how can I revert the changes?

 

Thank you in advance for your comments.

 

Kind regards

Petra

 

 

5 REPLIES 5

Re: Difficulties to change search settings in wt.properties.xconf

It looks like there is a non-ascii character in your command line.  We know this because of the "á" in the response.  Run your command through Notepad++ or other text editor first and replace what look like spaces with confirmed spaces.  Then your command should run just fine.

Re: Difficulties to change search settings in wt.properties.xconf

Hi, thanks für your answer.

But this was not the solution to set this property.

Both with and withour "r" in enterpise, this error occurs:

 

0 [main] ERROR com.ptc.windchill.structconf.StructConfManager - Extra unrecognized arguments: "com.ptc.windchill.enterpise.search.advancesearch.enableEmptySearch=true"

Re: Difficulties to change search settings in wt.properties.xconf

Following articles:

https://www.ptc.com/en/support/article?n=CS231329

https://www.ptc.com/en/support/article?n=CS187657

This worked for me (on Windows OS).

Copy the line from CS187657 into Notepad++ or other high-functioning text editor.

Retype all spaces and dashes to get rid of the Unicode issue.  This is why you got the first error.

Replace the double spaces after the "-s" with a single space.  This is why you are getting the second error.

 

xconfmanager -s com.ptc.windchill.enterpise.search.advancesearch.enableEmptySearch=true -t codebase/wt.properties -p

 

Note: PTC's comment about the forward slash on UNIX and the backslash on Windows isn't accurate.  The xconfmanger command accepts the UNIX style slashes for the "-t" term even on Windows.  Been typing it as shown above since Windchill 4.

Highlighted

Re: Difficulties to change search settings in wt.properties.xconf

You can also always manually update the site.xconf via a text editor to update the property by adding the following:

 

<Property name="com.ptc.windchill.enterpise.search.advancesearch.enableEmptySearch" overridable="true" targetFile="codebase/wt.properties" value="true"/>
 
After saving the file you will need to run
 
xconfmanager -p 
 
to propagate the changes.

 

 

Re: Difficulties to change search settings in wt.properties.xconf

Hi @Petra ,

I too get such exceptions/errors often. I then prefer to type the command rather than copy and paste from notepad or any other editor.

Can you explicitly type the command in Windchill Shell and see if you still get this error?

 

I hope this will get pass the error.

 

Regards,

Shirish