cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Difficulties to change settings in wt.properties.xconf

Chris17
11-Garnet

Difficulties to change settings in wt.properties.xconf

Hi there,

our users required to enable the search for empty attribute fields. The Windchill documentation states that this can be done by setting the property com.ptc.windchill.search.queryBuilder.enableNullCriteria in wt.properties.xconf to true.

 

I am used to edit settings with the xconfmanager tool. The command

xconfmanager -s com.ptc.windchill.search.queryBuilder.enableNullCriteria=true -t codebase\wt.properties.xconf -p

failed with a lengthy error message (see attached file).

 

In the wt.properties.xconf file, a comment has been inserted at the beginning:

 

#-*- XCONF CONTENT START -*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-
# WARNING:
#
#    This file has been updated by the xconfmanager tool located in,
#    $(wt.home)\bin but this file is not declared by PTC as being managed
#    via xconf.
#
#    To ensure that your settings will be preserved the next time the 
#    xconfmanager is run or an installer is used to install a new product or
#    a maintenance update to the currently installed products:
#
#     ****    DO NOT MODIFY THE CONTENTS OF THIS FILE DIRECTLY!    ****
#
#    If you are configuring this installation and you wish to change a value
#    from its default,  edit your site-specific xconf configuration file:
#       C:\ptc\Windchill_11.0\Windchill\site.xconf
#    using the xconfmanager tool located in $(wt.home)\bin.  You may run the
#    command 'xconfmanager -h' to obtain a usage statement for this tool.

#    The following properties are specified in xconfs:
#      - com.ptc.windchill.search.queryBuilder.enableNullCriteria
#
#-*- XCONF CONTENT END -!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-!-*-

So my question is: How do I properly set options in wt.properties.xconf? And how can I revert the changes?

 

Thank you in advance for your comments.

 

Best

Chris

 
1 ACCEPTED SOLUTION

Accepted Solutions
Vincent-Kulak
13-Aquamarine
(To:Chris17)

Target file is incorrect in your command

 

xconfmanager -s com.ptc.windchill.search.queryBuilder.enableNullCriteria=true -t codebase\wt.properties -p

 To revert to default you need need to remove entry from site.xconf and propagate with following command:

 

xconfmanager -p

View solution in original post

7 REPLIES 7
Vincent-Kulak
13-Aquamarine
(To:Chris17)

Target file is incorrect in your command

 

xconfmanager -s com.ptc.windchill.search.queryBuilder.enableNullCriteria=true -t codebase\wt.properties -p

 To revert to default you need need to remove entry from site.xconf and propagate with following command:

 

xconfmanager -p

Problem solved! Thanks a lot for your help, Vincent-Kulak!

arunk
4-Participant
(To:Vincent-Kulak)

change of property value :

We can run the correct value icon manager, and it will be updated with the updated value.

For removal of the property value: (sample)

xconfmanager --remove -s wt.mail.properties=\\$WT_HOME\mail.properties -t codebase/wt.properties -p

 

But it removes only value. Not the property itself.

After running this the wt.properties will have the below line.

> wt.mail.properties=

I would like to remove the property itself. Please help me.

 

 

BenLoosli
22-Sapphire III
(To:arunk)

xconfmanager --remove -s wt.mail.properties=\\$WT_HOME\mail.properties -t codebase/wt.properties -p

 

run this command:

xconfmanager --remove wt.mail.properties -t codebase/wt.properties -p

 

Your command is trying to remove and SET (-s) the same option.

 

arunk
4-Participant
(To:BenLoosli)

Hi,

I used this command, but not removing the line from wt,properties file.

arunk_0-1618235042361.png

 

BenLoosli
22-Sapphire III
(To:arunk)

I have had that happen before.

run: xconfmanager -d wt.mail.properties

See where the command  is being set from and if it has any value(s).

I have sometimes manually removed lines from site.xconfig and then run xconfmanager -p and that has cleared some of those pesky commands.

Last resort is to manually remove the entry in wt.properties, but be sure it is not in any *.config files first. I know, PTC says do not edit this file but there times when you have to.

 

I have been a Windchill admin for 18 years since 6.2.6 DSU11, now on 11.0 while working an upgrade to 11.1 and then 12.2.

 

 

arunk
4-Participant
(To:BenLoosli)

It works!

I removed the lines from site.xconf file.

And, ran the xconfmanager -p command.

Thank you.

Announcements