cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Drawing Losing Links to Parts Upon Revise

Regular Member

Drawing Losing Links to Parts Upon Revise

10.1 M040

I am observing the following behavior when an EPM Document drawing is revised from A to B.

Data Setup:

1. Models: Generic with 3 instances.

2. Drawing: 1 instance is detailed on the drawing which creates a dependency in Windchill to the generic and the instance. There is no dependency between the other 2 instances and the drawing.

3. Upon checkin of the models and drawing, WTParts are created and auto-associated. A preference is set to create a Content link from the WTPart for 1 instance and the drawing.

4. A user must manually create a Content link between the other 2 WTParts and the drawing.

[cid:image002.png@01CFE938.D9FB7710]

Behavior:

1. In our business, we allow the engineer to revise the drawing only to correct spelling mistakes and the like (NON form/fit/function).

2. When the drawing is revised, all of the Content links to the WTParts are lost. Windchill only shows a Calculated link from 1 WTPart to the drawing because of the dependency link to the instance.


[cid:image003.png@01CFE939.440A3100]

Does anyone know of a way to carry forward the Content links from the drawing to the WTPart when only a drawing is revised?

Patrick Williams | Engineering Systems | c: 616.947.2110
[cid:image004.jpg@01CFE939.5EE8B370]

1 REPLY 1

Drawing Losing Links to Parts Upon Revise

Revise by part, delete part?




Announcements
LiveWorx Call For Papers Happening Now!