cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Error after updating from 10.2 M020 to M030: "Data marked not to be published. No publishing will take place."

Highlighted
Regular Member

Error after updating from 10.2 M020 to M030: "Data marked not to be published. No publishing will take place."

Hi!

After updating from Windchill PDMLink 10.2 M020 to 10.2 M030 we have issues concerning the publisher.

The goal is to open Creo View with the default representation of a specific EPMDocument.

This is the direct link we usually used:

https://XXX.com/Windchill/wtcore/jsp/wvs/edrview.jsp?&viewIfPublished=1&sendToPublisher=OR:wt.epm.EP...

This does not work for standard users (non admins) anymore. The HTML output is:

Data marked not to be published
No publishing will take place

If an admin opens the URL, it works and Creo View is being loaded with the correct representation.

After reading in the PTC Windchill Visualization Services Guide, I checked the following Windchill Visualization Service Properties:

webpage.allowpublish.designcontext
webpage.allowpublish.epmdocument
webpage.allowpublish.wtpart
webpage.allowpublish.wtdocument
webpage.allowpublish.wtpartalternaterep

The description says:
Default Value: True
Synopsis: Allows publishing from the user interface by object type.
Description: Provides the ability for a user to publish from the user Interface on a type basis. If set to True, all users can publish the specified type from the user interface; if set to False, no users can publish the type from the user interface. If set to Admin, only administrators (system, project, or product administrators) can publish from the user interface. These Settings affect only the UI, and not the ability to publish via listener (such as checkin) or a schedule job; but being in the prohibition list prohibits such actions.

They are all set to "TRUE" but the behaviour is like they were set to "ADMIN".

Can anyone confirm this behaviour in 10.2 M030 and has a solution?
Or is there any other option I need to check?

Thanks!
David

1 REPLY 1

Re: Error after updating from 10.2 M020 to M030: "Data marked not to be published. No publishing will take place."

Do you have a publish filter in place? I can confirm that in our test system - 10.2 M030 this URL works fine for even non admin users as well. Do you see any additional errors in MS or BGMS log? Also can the user publish items from representation table?

Regards

Binesh Kumar

Announcements

Thingworx Navigate content has a new home! Click here to access the new Thingworx Navigate forum! ______________________________ Check out the Windchill Tips Board! We're talking about Whirlpool's use of digital twin, augmented reality, and data-driven design!

The NAVIGATE WORKING GROUP is here! Come innovate with PTC!

Sign up for a Working Group