cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Family Table tree is not getting populated

Highlighted
Regular Member

Family Table tree is not getting populated

Let me describe my problem ..

 

We have consolidated two instances of same versioned Windchill system into one..

Now we are observing some issues with Family table.

 

For doing this, we have used custom method to load metadata & Content and then creting links for those loaded metadata.

 

But the present situation is that we are facing problem with FT objects.

-   For genric part,  member in Family Table tree is crossed ( atatched the screen shot )

-  For Instances,  Family Table is not getting populated.

 

I am looking for cause for this, then only I can able to understand which step of migration went wrong or which has to be repeated to correct it.

 

advise related to this would be very helpful in proceding furthur ..  we are actually stuck at this point ..

3 REPLIES 3
Highlighted

Re: Family Table tree is not getting populated

Highlighted

Re: Family Table tree is not getting populated

Hi, when combining data like that FT members cannot exist in two or more models at the same time. If you already have x.prt in a family table then you would have to either rename the new version or the old version so that the model only sees it in one location.  One place I used to work in used multiple sites before combining data so they used suffixes on the FT's to get the data in.  All users knew this data was not fully validated until it adopted full compliant numbers because they were smart enough to educate before the migration.

 

The same applies when it comes to deleting. Don't ever delete an FT member as if it is called in then CREO will pull in the old model that contains it.  then if you have new members in the table creo trys to pull in x.prt version A.99 that has the old instance that was deleted and x.prt version c.23 with a new instance in it. They both can't be in session at the same time.

 

Highlighted

Re: Family Table tree is not getting populated

Thank you for the reply ..    Now we are iterating the latest version of FT on target site by a disabling FT validation check , later enabling it.  loading all FT via workspace export import method.

Announcements