cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How to not display family table instances in Windchill

SOLVED
Highlighted
Newbie

How to not display family table instances in Windchill

Hi,

I added this part in my Windchill 10.2 workspace from a family table and it occurs that this family table is pretty big.

Is there a way to only display the generic part and not see the whole list in my workspace, or only the instance I use?

My assembly have something like 10 parts but they are flooded in 300 instances of a screw...

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: How to not display family table instances in Windchill

This can be handled very easily using a filter in your workspace.

Use a custom create a Object List for your workspace and toggle this as needed.

Create a new view and in the Set Filters, select the Instance Criteria Equals to NO as shown in the attached image.

Applying this filter will not display any instances in your workspace. Whenever you need to see the instances you just need to change the filter to default one.

View solution in original post

4 REPLIES 4
Highlighted

Re: How to not display family table instances in Windchill

Check the preference settings for downloads. There is one that will only download the instance and its generic when you open an assembly and pull the data into your workspace.

Highlighted

Re: How to not display family table instances in Windchill

This is really a process issue...the goal should be getting the job done as fast as possible with least amount of clutter!  If you are clicking the button for add to workspace to open a file in Creo Parametric you have already wasted steps.  And then if you have collector settings to include all instances then you are asking for clutter.

Next time, try pasting or typing the assembly or drawing number into the File open dialog box in Creo Parametric UI and let Creo bring in the objects to workspace.  I have done many time tests and the process is faster with this method.

Highlighted

Re: How to not display family table instances in Windchill

This can be handled very easily using a filter in your workspace.

Use a custom create a Object List for your workspace and toggle this as needed.

Create a new view and in the Set Filters, select the Instance Criteria Equals to NO as shown in the attached image.

Applying this filter will not display any instances in your workspace. Whenever you need to see the instances you just need to change the filter to default one.

View solution in original post

Highlighted

Re: How to not display family table instances in Windchill

Gentlemen, thank you for your help!

Announcements